Stream Deck - Open Stream Deck Group with Name appears to be Touch Bar Group

Describe the bug
Using Stream Deck fully controlled by BTT. Trying to setup a Stream Deck button to open an existing button group with a name of "x". All seems straight forward, but when I select the Open Stream Deck Group with Name option from Actions list, I'm presented with an action that actually seems to represent a Touch Bar Group with a specified name. Ignoring that and entering the name of my Stream Deck button group generates the button, but the button has no effect.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Not really an input related issue?


Device information:

  • Type of Mac: MBP16 M1
  • macOS version: 13.2.1
  • BetterTouchTool version: 4.065
  • Stream Deck MKI

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I really hope it's not something stupid I've done, but I'm reasonably sure I've approached the setup correctly.

Maybe I am misunderstanding your issue, but I am opening groups on my Stream Deck by creating a group and populating it with actions. This works perfectly.

Yes, what you're describing works absolutely fine. But I have page/level/group/folder where I want re-use an already existing folder/group. I don't really want a duplicate folder of actions (so if I want or need to change anything, I only am making the change in one place).

So, for clarity. I'm trying to create a button that is simply a "link", if you will, to an existing folder that is actually at the top level/page.

It's working for me. I created the groups "group1" and "group2" on the top level. If I create a Stream Deck button with the "Open Stream Deck Group with Name" function in "group2" and specify "group1" as the "Stream Deck Group Name", then the view automatically jumps to the "group1" when the button is activated. Or am I still not getting it?

Sounds exactly like what I'm trying to do.

So i tried it again, but this time:

  • I removed a space from the group name
  • Renamed everything verbatim as your example
  • Removed the fixed position config from the "link" group
  • Created a new "link" group button from scratch

None of which make any difference for me. Now I'm getting frustrated at this point because it's working correctly for you, so it must be something I've configured right?

Well, yes! At some point, I must have clicked the checkbox for "Keep group open while switching apps." on what would be "group2". I unchecked this and all my newly created test buttons & the original button all work perfectly.

So my real issue is sorted, but can I confirm that when you go through the creation of the "Open Stream Deck Group with Name", the description under the "Stream Deck Group Name:" field says "...the Touch Bar Group..." as in my screenshot?

So, in the end, not a bug in the operation, just a typo in the description, combined with my unique config circumstance had me wandering down the garden path for a bit.

1 Like

That's great that you managed to do it. The spelling mistake is there - I can confirm that.