Stream Deck Mini Not Recognized by BTT

Hello, I have recently purchased a Stream Deck Mini (the 6 button one) and I cannot get it to be recognized by BTT. The buttons just show the default Elgato logo and that's it.

I have "Fully controlled by BTT" enabled. I have restarted everything multiple times. I have tried every single USB port on my computer.

I can see the Stream Deck in the System Profiler:

To try and get it working, I installed the official Stream Deck software. The Stream Deck device itself works using the official software. I can also seem to use it OK when I swap BTT to "Stream Deck Plugin" mode. (Groups didn't seem to work, but I didn't look too far into it) I uninstalled the Elgato Stream Deck software after confirming that the device does actually work. (Just to confirm, if I plan to use only BTT to control my Stream Deck, I don't need the Elgato software on my computer, right?)

Nothing I do can get BTT to "see" the device. I even looked under "Only show on specific devices" and I don't see anything under "Currently Connected"

I am on the latest version of BTT (4.069). My machine is the newest MBP (16 inch 2023, running Ventura 13.2.1)

Thank you for your assistance!

I can confirm that via “Stream Deck Plugin” mode, it does indeed work without any issue. Now I have no use for the official plugins and intend to only use BTT for configuration, so I’d be happy if I can get the more performant method working… but BTT refuses to acknowledge the Stream Deck Mini exists.

Hi, I still can't get BTT to recognize the Stream Deck in "Fully Controlled" mode. This is unfortunate because "Stream Deck Plugin" mode is kind of buggy.

For example, when my Macbook wakes from sleep, the buttons appear on the device, but do not actually function. The only way to fix this is to manually close the Stream Deck app. This causes BTT to fire the "No Response - Restarting Stream Deck App" process which then restarts the Stream Deck app and makes the buttons work again.

Ideally, I could get "Fully Controlled" working in BTT which would eliminate the need for the Stream Deck App in the first place. Is there anything I am missing as to why BTT does not "see" my Stream Deck Mini in Fully Controlled mode? Thanks!

I have connected two Streamdecks, one XL and one MK2. Both are working perfectly fine in fully controlled mode. I briefly had a Plus as well, but I returned it because the functionality is not yet fully supported and it didn't benefit me. I know this doesn't actually help you, but before nobody responds to the calls for help, I just wanted to give a sign of life.
You could try posting how you're attempting to address the Streamdeck to get more detailed information.

It should look similar to this.

1 Like

Looks like your version of the mini is newer than the one I tried - your product id is different.

I'll add the product ID to the next alpha version, maybe it will just work then. If there have been deeper changes to the device I'll need to check again.

1 Like

This was my gut instinct as to the problem!

This is the newest version of the Mini. Hopefully it’s just as simple as adding the ID to the list. If there’s any kind of other diagnostic dump you need to help identify it, let me know how I can help!

Thank you for your hard work. I just got a new MacBook and started from scratch; BTT was the very first piece of software I reinstalled. It’s that useful :heart_eyes:

I have the same issue with a Stream Deck XL. Here's the information from System Information:

@Andreas_Hegenberg i just updated to 4.070 and can confirm that it works in "Fully controlled" mode now.

Thank you very very much. <3

@Dave_Kammeyer hopefully this update fixes it... if not, Andreas will probably just need to update the product ID for you.

1 Like

I am having the same issue as Dave_Kammeyer.
I have the same Product ID with my Stream Deck XL.
Apparently, 4.070 did not fix the issue for Stream Deck XLs with that Product ID.

Also confirming that the 4.070 did not fix the problem for me. Unfortunately using the streamdeck in non-native mode is very frustrating. Every time I wake from sleep I have to restart BTT and the streamdeck app, and restarts also happen every hour or two just while using the computer.

Looking forward to an update so I can use it in the native mode!

I can confirm this is fixed in 4.072