Stream Deck: Hide global triggers not working....

I posted this under another category here....a fair number of views but no responses, so I though perhaps it needed to be here instead. Apologies in advance if I am breaking a forum rule!

I am not sure if this is something I am doing wrong or a bug.

I am using BTT to control a Streamdeck XL. BTT has full control, not using the Streamdeck plugin.

I have created a layout of buttons in the "All Apps" category, and a other layouts that are applied to specific applications, eg Finder. In the Finder setup, I have clicked the checkbox for "Notch / Action Bar & Stream Deck" to "Hide Global Triggers."

When I switch to Finder, however, most of the the Finder-specific StreamDeck buttons appear, but some do not. Where the Finder specific buttons appear, obviously the "All Apps" buttons are now hidden. Where the Finder specific buttons do not appear the "All Apps" buttons are still visible, and where there are NO Finder specific buttons set, the All Apps buttons are also still visible. My expected behavior is that all Finder specific buttons would be visible whether overlaying All Apps buttons or not, and any location where there is an All Apps button but no Finder specific button, the All Apps button would no longer be visible.

I don't know if this is a bug, or I am doing something wrong.

I have tried this on two computers, one with the SD attached, the other with all of the profiles imported and looking at the StreamDeck Emulater/Preview.

My version of BTT is 4.068 through SetApp, which I just checked and appears to be the latest version available there. I have NOT tried the latest alpha release because I have BTT through SetApp.

This behavior is seen on a Mac Studio M1 Max and a MacBookAir M2, both running Monterey 12.6.


FWIW, I am having the same issue. I have a global set of buttons, most of which do not have row/column assignments (I do have a few that do have fixed positions ==> weather, music playback). I also have a set of app specific buttons. But when I activate Mail, some of the Global buttons appear overlaying some of the Mail specific buttons. Iā€™m chalking this up to this feature still being more or less a beta feature and am hoping that @Andreas_Hegenberg has fixes in the works.

@gwhizkids Thanks. It's at least helpful to know that I am not the only one experiencing this issue; you are the first to reply to my posts.

I have now installed BTT on a new computer running up to date Ventura and still have the same problem, so it is not specific either to Monterey or one computer.

I did some experimentation, creating a new conditional activation group active only when Finder is the active application, and moved all of the SD buttons there and removed the Finder as an app. This did not change the behavior (I thought maybe there was a weird glitch with something in the data files).

I find that the same thing happens with other apps as well, but somewhat inconsistently, whereas with Finder it is always the same buttons that do not get replaced from the global configuration to the Finder specific buttons.

1 Like