Stream Deck buttons mostly don't work anymore

Describe the bug

I've been using BTT with my Stream Deck for about a year now, controlling around 30 apps with it.

It worked fine until a few days ago. Now all of a sudden, most of the Stream Deck buttons have stopped working. I have a suspicion this has to do with the recently added feature that allows to configure actions separately for button down, long press and button up.

I've tried to diagnose the issue, BTT seems to "decide" randomly if a Stream Deck button works or does nothing.

To demonstrate, please find the preset attached. It has two Stream Deck buttons that are supposed to do the same thing – print some text – but only one of the button works.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Elgato Stream Deck MK.2 (15 keys)



Device information:

  • Type of Mac: MacBook Pro 16", 2021
  • macOS version: Sonoma
  • BetterTouchTool version: 4.583

Additional information (e.g. crash logs, related issues, etc.):

MacVim_export.bttpreset (10.9 KB)

I just tried your preset, but both of the buttons seem to work fine here. Are you using the Stream Deck in "Fully Controlled By BTT" or "Plugin" mode?

Does the other button do absolutey nothing in your case or does it only trigger the up or down actions?

Thanks for the quick reply!

You know what, you can close this issue…

I've found out that it's actually the hardware's fault. The leftmost 3 buttons on my Stream Deck have stopped working. It's the same issue when I don't use BTT at all. I've tried it on a Windows machine with the stock Stream Deck configuration app, it's the same problem.

1 Like

Oh man, that is unexpected - it's the first time I hear about a broken Stream Deck ;-(

Yes, weird, it's only 1.5 years old. But I got a full refund from Amazon…

1 Like