Stop listening to commands

I'm trying to use a MIDI surface (Arturia Beatstep) to control Davinci Resolve, emulating mouse clicks and drags, or keyboard shortcuts.

It's working pretty well, except I had to find odd workarounds.

It seems to me that pressing buttons or turning knobs will generate not only one but many iteration of the same command, so BetterTouchToll will run the scripts many times consecutively.
How can I make BTT stop listening to the midi surface, as long as its executing the script, and only then, start to listen inputs from the midi surface again?


I think there is currently no good way to disable the recognition, but I can add an action to achieve this.

Could you maybe post the output of the BTT "Midi Event Viewer" for such problematic events?+

Simplest command: knob 0 is used for frame to frame scrubbing, emulating a left or right arrow press on the keyboard, shortcut for going to previous or next frame… (MIDI value is 63 when turning knob to the left, 65 to the right)

If I do it with CommandPost, it’s very snappy: it stops scrolling the timeline as soon as I stop turning the knob.
With BTT it stops a bit later, depending on how much I turned the knob.

On this screen capture I tried to go one frame left, then 2 frames right. BTT midi viewer recorded 2 left, 3 right.

For more complicated stuff: emulating mouse click and drag, here you can see that I had to add a delay, the move of the mouse (Davinci was perceiving a double clic, so it was reseting the parameter all the time) and another delay to make it work.