Somehow automatic updates stopped functioning, and app doesn't respond after wakeup.

See attached screenshot.

It has the automatic update box checked (since I installed it years ago) and yet the update pending is from may.

I discovered this because all of a sudden (since a few days) BTT crashes on wakeup.
Thus, I thought perhaps something updated, and checking for updates actually showed me that it didn't update since months.

I then tried to install that update and all I got was the ominous Mac Rainbow spinner for a good while.
After, it said "Installing update" for another very long while with the bar stuck at 80% ca. As the update finished, BTT didn't restart. When I manually restart it, it takes minutes to fire up.

This all just started some day ago without an other app being installed or update being performed.
When I reopen it, the Touch Bar still shows Mac defaults.
I need to restart it again, which again takes minutes, shows the rainbow spinner on the top menu bar, and again after restart, BTT is not shown on the touchbar. Keypad and touchpad become unresponsive, and basically, well, it seems broken :frowning:

I need to then click the BTT icon on the Touch Bar to actually activate BTT.
And as soon the Mac goes to sleep, the game starts again.

This is on a MacBook Pro (16-inch, 2019), all things updated regularly (unless as above stated, BTT).

BTW this bug here pretty much sounds similar:

I also see this (as described above, after restarting twice, I still need to press that button, which half the time does nothing either).
And here is another one with the very similar issue:

But all these reports do not show the exact same issue which I see, which is that BTT completely crashes on wakeup.

And there is a third report:

And what seems once another one!

Thoughts?

I konw ... Maybe this is an unattended problem.
I've given up any hope.

don’t worry about the updates, I haven’t pushed a stable release for quite a while but I’m in the process of releasing one today:-) (the release notes show update info that is not relevant to all users when checking manually)

About your issue, could you go to help-> export diagnostic debug information and send the result to andreas@folivora.ai? This could be caused by various things. If it really crashes, could you also go to the macOS console.app and copy all BTT crashlogs from the "Crash Reports" section?

Did anything with your hard disk or network disk setup change? Sounds like some file access might take a long time.

1 Like

I’ve uninstalled Avira and since then it seems better

Avira is an antivirus/scan app. Thus it could interact with permissions I guess.
However - let me test it for a day or two to see if that was it.

And it might be interesting then for all those other tickets with pretty similar behavior.
Perhaps they have some sort of antivirus too, or else’s file permission interactions from other apps?

I’ll send the logs Tuesday after I confirm or deny it to be solved.

OK so this started again.

However, there are no crash reports for BTT even if it is BTT that definitely crashes (closes, disappears, whatever). Each morning I need to re-start it. Each wake Up I need to restart it.
But console shows no crash reports for anything related to BTT.

Actually there are only crash reports about an app (MAMP) that I do not even use at the moment of crashing/becoming unresponsive, since this usually happens after wakeup from night over sleep (and I do not keep MAMP running of curse).

I have sent you the other logs from BTT to the email, but probably the issue is not due to BTT, since there are no crashlogs related to it. Annoying, because it certainly seems to be BTT (however, it could be any other thing blocking BTT from doing its job).
Typical Mac to work fine for ever and then just stop working fine from one day to the other, because the moon turned its face, or whatever.

Let's hope you can find something on those logs, however as said, the more this happens, the more I see no crash reports of BTT, the less I actually believe it is BTT due.

@Andreas_Hegenberg - Did you receive the email?
Just making sure it did not go to spam, not to stress you out :slight_smile:

Imprint | Privacy Policy