Solved: MacOS: BTT not starting, stuck in a loop (GDPR / DSGVO) — reason: setting-backup program installed (Mackup)


Describe the bug
This is a quite annoying bug. I accidentally closed BTT this evening, and after reopening BTT, it asked me a couple of questions regarding the updater, asked me to put my admin password, and then asked me GDPR questions. However, it somehow got stuck in a loop, and I had to input my password several times, and never got it to work properly. I closed BTT, and now there is another loop, between the GDPR screen and the next screen (see below). I haven’t updated my Mac yet, but since I don’t think this should happen in any case, I thought you would appreciate me posting here.


Device information:

  • Type of Mac: MacBook Pro M2
  • macOS version: 14.5 (23F79)
  • BetterTouchTool version: since it’s not starting anymore, not easy to find out. In the Finder, it says the version is 4.564

Have a great day

Even after restarting my MacBook — I can’t start BTT anymore, always the GDPR-Loop between the two screens above. @Andreas_Hegenberg

Also took the latest version from the website, still no luck. Something must have messed up my options?

this is some file permission issue. BTT is not allowed to write to its own settings file.
Did you recently restore your Mac from a backup, change your username or install some app for syncing settings?

The easiest way to solve this, is to delete the BetterTouchTool settings file, then BTT will create a new one with the correct permissions.

1 Like

Oh, thank you! That was it. I’m so sorry I didn’t find out myself.

Indeed, I installed Mackup. And what happened is that Mackup replaced the settings file with an alias, and put the original in the Mackup-Folder, to be able to sync it. I simply copied the original from the Mackup-Folder back to where it’s supposed to be, and everything went back to normal.