[Solved] Doesn't launch when startup

Hello,

I noticed that BTT doesn't launch automatically when turn on my computer recently.

I tried to add it to the login system on the MacOs Setting system and
turn it On on BTT general basic setting but it doesn't work.

I use MacOs 11.1
BTT 3.505

Best

Possibly try to remove it from the login items then toggle the setting in BTT. It can get confused when being added to login items manually.

Thank you for your reply.
I tried without login it on MacOS setting but it didn't launch either.

Are you sure it is not starting or is just some functionality not working? Did you toggle the setting after removing it from the login items? (It needs to be in there but it needs to be added by BTT)

Thank you it is solved!
I switch on and off the "Launch BTT on startup" button on BTT after removing it from
MacOs User system Login item and it start automatically😊

Hello,

I'm having this issue too but I wasn't able to solve it by doing the above steps. I'm on an iMac OS Monterey 12.3.1. I have the Launch BTT on startup ticked under Settings and tried with having BTT added and removed from the login items. It still doesn't launch on startup. Is there anything else I can try?

Same here. The BTT does not automatically login on system restart.
The BTT preference log in on restart is checked.
Try adding and removing the BTT app from the OSX log in items.

The problem is present on OSX Monterey intel-based macs and M1 mac.