Snap areas stopped work when dragging a window with a normal mouse

OS Sonoma 14.2.1
BTT 4.361

When dragging a window using trackpad or a normal mouse, snap windows appear on the screen and dragging to them changes the window per settings, and dragging to top of window would expand the dragged window to 100% screen. This is still working with my trackpad.
However it recently stopped working with my trackball, regardless of BTT version or computer reboot. I haven't changed anything on the trackball for years, no updates or changes in the configuration. The trackball is working fine on everything else, including trackball BTT configuration snapping a window to a location using the trackball -- but for some reason, now when dragging a window with the trackball, snap areas don't appear and snapping via drag to top of window doesn't work -- but only for the trackball.

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

is your trackball doing a standard left-mouse drag? or is it some special dragging?

Nothing special -- I use SteerMouse to assign "primary click" (left-mouse click) function to a button on an Elecom Huge trackball HUGE Wireless Trackball

It's been working fine for at least 5 years, but I think it stopped working in the last month, either with latest Sonoma update or a recent BTT update. The trackball and steer mouse setup, software and firmware haven't changed.

Any insights yet on change in behavior? I'm guessing something in Sonoma changed which caused the change in BTT behavior.

FYI - I looked into this and BTT version from 2022-12-30 does not have the bug. Sometime between that version and the existing version the snap windows stopped appearing when dragging with a mouse where left-click is reassigned to another button.

The mouse is accurately sending a left click - works fine - but BTT stopped recognizing that reassigned left click at some point.

It still works on the trackpad, but not the "normal mouse" functions of BTT - but it used to as evidenced by the 2022-12-30 version of the app.

I guess I'll stick with the BTT version from 2022-12-30 until this gets fixed. I use the top-screen, snap to full window size feature all the time on my second monitor, and I'm used to doing it with the mouse.

are you sure you mean 2022? Not 2023? So more than a year ago?

That would make it even weirder because
I don’t think there have been similar reports so far.

I’ll make a couple screen videos so you can see yourself. I tried the app from 2022-12-30 and the issue does not exist in that version. If you want, I can keep trying legacy versions until I find the one where the bug appears.

Again, this is happening when steermouse is used to map leftclick to another button on a “normal mouse”

I found when it broke using this page Index of /releases

The described function worked all the way to btt4.351-43510, uploaded at 2023-12-14 22:20

On the very next uploaded version btt4.352-43520 uploaded at 2023-12-15 09:36, the function broke

It was still broken at btt4.364-43640 uploaded at 2023-12-29 23:06

And it is still broken at the version I installed today: btt4.402-44020 uploaded at 2024-02-13 12:04

thanks, I’ll check what changed between these versions!

Did this ever get checked/fixed? Thanks.

Yes, this was fixed a few months ago!

I tried just now (by updating from 43510 to 45040) and it stops working. When I go back to 43510, it works again.

See attachment. Green is where it works, red is where it stopped working.
Screenshot 2024-05-10 at 11.07.21 AM

Damn, then your issue is a different one.
I'm also using it with a normal mouse and even remapped a button to test within BTT, but I haven't tried with SteerMouse.

You could check whether the high level mouse event setting helps

(this setting causes BTT to listen at a higher level, which can be a bit slower but is the only way to work along with other apps that modify the mouse event stream)

Just went to 45040 again > normal mouse settings > use high level mouse event recognition & restarted BTT -- still broken.

Went back to 43500 this time instead of 43510 and it works again.

You changed something between 43510 and 43520. That's exactly where it broke.

Oh is it possible that SteerMouse generates incorrect drag events for the remapped button?
Between these versions a bug in BTT was fixed that caused various other mouse related issues because it listened to all drag events and not only to left mouse drag events.
Maybe Steer Mouse doesn't generate "Left Mouse Drag" events although you remapped the button to left mouse.
Can you try to run this terminal command while BTT is quit? (this will make it listen to all drag types again, which is bad but might help)

defaults write com.hegenberg.BetterTouchTool BTTWindowSnappingMiddleDragEnabled YES