Snap Areas only work with BTT windows

Dragging a window with a modifier key for snap windows only works with BTT application. Previously, you could move a window and while dragging, press/hold a modifier to get snap areas to populate while dragging, but no longer. Also noticed that key sequences no longer trigger snap areas as it did previously.

Possible culprits per changes I made might include midi or named triggers, but reverted to previous settings, deleted new triggers, and still no change despite changing settings and several restarts.

Device information:

  • Type of Mac: Mac Studio Apple M1 Ultra 128 GB Memory
  • macOS version: Sonoma 14.2.1
  • BetterTouchTool version: 4.41

I don't think there has been a change to this.

Just to clarify, you mean you have some snap areas that have modifier keys defined like this?:

And they don't show up when you press the modifier key?

Correct, dragging a window with a modifier key and no snapping windows or behavior except when dragging a BTT window. Works as expected with BTT but not with any other window i.e. Chrome, Finder, Safari, etc. None of the snap windows have any applications specified in their settings.

Seems to work fine here. Have you already tried to restart your system?
Possibly try to remove BTT from System Settings => Privacy & Security => Accessibility, then add it back manually using the + button there

That was it! It was selected, but the retoggle did the trick. Thanks for your hard work Andreas! I use this program every day and still find new things!

1 Like