Snap Areas not working outside of BTT application. And Clicking is weird.

I bought a new M2 Macbook Air running 13.4.1 and the latest BTT version (upgraded to today's Alpha version 4.133). I migrated my old MBP 16" to it, but noticed BTT not working properly.

One thing is that the Snap Areas only work when I try it on the BTT window. It does not work in Mail, Safari, or any other app i've tried. It worked on the MBP always for months, daily.

Another thing to note: my trackpad shortcut to snap windows to the left/right/fullscreen/3rd of a screen, all work. But clicking and dragging a window to the left/right/corner, etc. does not work.

2nd Issues: "Clicking is weird"
For example - 4 finger click is set up to Close Window. But after switching to Macbook Air, 4-finger click still "clicks" but does nothing. But it will work if I keep pressing and hear a 2nd click - then the window will close.

I noticed that pressing hard enough for a 2nd click is required for my other BTT gestures that require a click. For example, I disabled two-finger right-click in System Settings, and enabled it in BTT, but it won't work unless I press hard enough for a 2nd click to register.

Any idea what is going on? Hopefully I just need to change a setting.

To make the clicking bearable, in Settings, in Trackpad, in FORCE Touchpad, I have reduced the "Pressure necessary to recognize normal clicks" to the lowest possible setting. I have also selected "No Feedback" for the "Haptic response for normal clicks) setting. However, it still does two "clicks" when I release a trackpad click that triggers a BTT command. For example, 4-finger click to close a window results in 1 click, then the window closes when I release the click, but I feel 2 clicks upon release.

Oh, could you go to Help => Export Diagnostic Debug Information in the BTT configuration main menubar and send the result to

I didn't have the chance to get my hands on a M2 Macbook Air yet, thus the new trackpad identifiers have not yet been added to BTT.

Thanks for fixing the trackpad issue.