Single finger force click doesn't work right

I've been using 'single finger force click' to trigger a double click for years now. Suddenly it no longer seems to work, at least in finder, and maybe in other places. Instead, what happens now is that when I force click on a folder, finder navigates to the previous folder that I had open. I've even tried completely deleting the force click trigger and it still does the same thing. I can't figure it out.

After using it a bit more I've discovered that if you restart BTT it will work correctly for one force-click in finder. After that one click it goes back to the behavior I detailed above, and also drawings are disabled.

I can't reproduce this here, assigning double-click to force click still works fine.

What macOS and BTT version are you on?

13.2.1 (22D68)
4.028 (2245)

I just tried installing the alpha update. Made no difference.

I also tried creating a preset with no triggers at all, not even one for single finger force click, and it still does the same thing.

If I quit BTT altogether, force click does nothing, as you'd expect, so the problem has to be with BTT.

I didn't change anything in any of the BTT settings, or to any of the MacBook trackpad settings before this started. It just came out of absolute nowhere.

I really don't think the issue is BTT, as the code for force clicks hasn't been changed since about 2 years (just checked).

I'd assume it's some system setting, but I currently have no idea which.

Maybe try to rename this folder while BTT is quit: ~/Library/Application Support/BetterTouchTool - this would get rid of any relevant BTT configuration (you can rename it back to get your config back)

What does the force click do in other apps like Safari?

Changing the name of the folder didn't do anything. Same thing happens even with a completely clean slate.

I thought it was working fine in everything else. I can force click Folders on the desktop and they open. I can force click on a YouTube video in Chrome and it opens it in full screen like it should. But when I try to do the same thing on a YouTube video on safari, or if I just force click anywhere on any page in safari, it instead jumps me back to the previous page I was on, very similar to what it does in Finder. That must mean something.

Does the live view in BTT show any recognized gesture when you do a force click?

(Main Menu => View => Live View)

This is just getting more and more confusing. It shows "brightness down" for some reason. The only thing I have set for brightness up or down is buttons on the Touch Bar. I tried disabling the button that is set for brightness down, but that didn't seem to change anything.

I tried changing the name of the application support folder again, and when I look at it in live view there, it shows force click as "double click", like it should. But it still jumps me back in Finder and in Safari.

After you renamed the folder it should not show anything, or did you add the force click gesture again afterwards?

Yes, I added it back. It didn't show anything before I did.

Very weird issue.

If nothing is shown in the live view, it means BTT doesn't execute any action.
If no trackpad gesture is configured, BTT doesn't even enable the gesture / force click recognition.

So I think something outside of BTT might do this, but I have no idea why this would only happen while BTT is running. Do you use any other automation / keyboard / mouse software?

I use Moom and Spectacle, I tried quitting both of them just now and the issue is still there.

Unfortunately I currently don't have any other idea. I have tested on my two other machines, but it behaves correctly there as well.

If I find anything I'll post here.

If you want you can go to Help => Export Diagnostic Debug Data and send it to, but I don't think it will help in that case :-/

I created a new user and imported my BTT settings to it. It works fine there. So the problem is something else on my computer, but I have no idea how to find out what. I've tried quitting everything I can. I guess I'll just wipe the computer, reinstall the OS, and start all over. I don't know what else to do.

maybe first try to reset the remaining BTT defaults with this command:

defaults delete com.hegenberg.BetterTouchTool

(while BTT is quit)

I don’t really think that will help, but reinstalling macOS over this sounds a bit brutal:-)

It seems like that fixed it. What does that mean? What exactly did that command do?

it got rid of the BTT user settings (not the trigger setup but the checkboxes and various values in the advanced BTT settings)

I have no idea what setting could cause such behavior though :-/

Well, I guess as I put those settings back to how I had them before, maybe we'll find out. I'll let you know. Thanks for the help.