Since update, BBT doesn't work after sleep mode.

MacOS Mojave 10.14.5. Since the most recent updates, when I close my macbook pro lid for sleep mode, then reopen it to use it, the BBT doesn't work on the magic mouse. Every time I re-open my macbook pro I have to restart BBT, to get the BBT features to work again on the magic mouse. I updated to 3.149, and after 1 day, same problem. Now there's 3.157, just updated today. My main use for BBT is magic mouse with browsers.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

As far as I know, this is fixed in the latest build.

I am actually still having this problem.

What I have discovered is that after waking from sleep, BTT does not work at all (keyboard shortcuts or trackpad). But once you switch to a different window (like if I was on Safari and then switch to Finder) it works again.

So when you wake from sleep, the only way to use BTT is to Cmd-Tab to a different program then again back to where you were so you can use BTT.

The problem repeats no matter how short the "sleep" session is.

Noticing the exact same thing as DETstru. Whatever window (say Safari) that's in focus when my Air wakes up does not work (default trigger no longer triggers) with BTT trackpad gestures. But as soon as I shift focus to another window (say mail) guestures start working (including when I switch back to the initial app). Just noticed the update (3.157) as I was typing this so I will give that a try and see if it fixes it.

Yup, I'm pretty sure this is fixed in 3.157

Looks like it has thanks.

I'm consistently running into this problem with BTT 3.186 on Mac OS 10.14.6.

if you want you can check the „restart after waking from sleep“ option in the settings. However the specific issue described here has been fixed a while ago. Possibly create a separate thread with more info and possibly send debug info to andreas@folivora.ai (debug info can be exported using the help menubar item in BTT)

Imprint | Privacy Policy