Since the latest update all my custom trackpad gestures fire twice (MBP laptop).

Since the latest update all my custom trackpad gestures fire twice (MBP laptop).

Which version of BTT are you currently running (sorry unfortunately "latest" doesn't tell mee because various macOS version / alpha / beta rollouts are happening all the time)

Are you sure BTT is only running once? What kind of gestures are you using?

It started happening with the update you posted when you first came back (last week or so?)

  • Currently on v. 3.280 Alpha (I took your advice and updated to the Alpha channel in the hopes that it was a bug and you fixed it). I usually stick to the Regular Updates channel. Mac OS 10.15.3.

  • BTT appears to be only running once. These are the processes running when I search Activity Monitor for "Better":
    Screen Shot 2020-02-02 at 2.04.39 PM

  • I'm using a few gestures (have had them for years, none are new, haven't changed any setting for around a year or two), but the ones I've noticed this happening with are a 5-finger Tap to hide the current application (alias of "Cmd-H"), 4-finger Click to mute (alias of "Mute"), 5-finger Click to Quit an app (now quits two in quick succession; an alias of "Cmd-Q"), and a 3-finger Click to switch to the last application (alias of "Cmd-Tab"). "Tip-tap"s don't seem to trigger twice, only moving the volume up or down one step (I use tip-tap left/right 2 fingers for volume control):

Thanks, Andreas and congrats on the newborn!

Same problem here, fire twice randomly
BTT: 3.279
macOS: 10.15.2 (19C57)
MacBook Pro 13-inch, 2017

Works fine before


  • For swipe gesture, fire twice randomly
    (3 finger swipe left/right to switch chrome/IDE tab)
  • For click gesture, fire twice with high probability
    (3 finger click trigger middle click to open link in new tab)
  • For double tap gesture, fire with one tap
    (3 finger double tap to close current tab)

Weird, could you go to the BTT preferences and in the main menu select „help -> export diagnostic debug informative " and send the result to me? (

Email sent.

Tiptap right (2 finger fix) gesture also fire twice

Thank you!
I think it's caused by the "Mirror complete Magic Trackpad" option in the preferences.

I'll fix it.

Should be fixed in 3.281 alpha which is currently uploading and will be available in a few minutes. Would be great if you'd check

Works fine on:

  • 3.279 with "Mirror" option off
  • 3.281 with "Mirror" option on

(Test build-in trackpad only)

Thank you!

1 Like

Yes, that fixed it for me, too.

Thanks, Andreas.