Showing/hiding widgets and buttons with modifier keys inside Button groups doesn't work properly

See the Screenshot below.
Basically Widgets and buttons that should appear only when a modifier key is pressed do not appear, Widgets that should disappear once you push this button aren't shown at all.
This happens only inside a button group, if the widgets or buttons are copied directly to the "Global" List they appear and disappear as they should.

Affected input device: Touch Bar (inside groups)


Device information:

  • Type of Mac: MacBookPro15,1 or MacBookPro15,3
  • macOS version: 10.14.3 Beta (18D38a)
  • BetterTouchTool version: 2.696

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Any ideas?
Thanks, have a great evening :slightly_smiling_face:

Seems to work fine here, are you sure it's not the other one showing? (Try to set a different size for both, then you should see them switching when option is pressed)

1 Like

Ok, this brings up the "normal" Application switcher (the one that's not associated with ⌘Q).
Still both of them do not respond to any modifier key (⌥ here, I also tried to change them without success).
The bar looks like this now, but the idea would be that once I hold ⌥, the normal app Switcher disappears in order to bring up the one that quits the apps [edit: and the Textbutton "Quit:", that should not have been there without any modifier key].

I think the problem may be that the system thinks you are executing cmd+opt+q in that case.
You can try whether the correct widget is executed by assigning an action like "Show HUD" or expose.

Try instead of cmd+q to assign the "Run Apple Script" predefined action and run a script like this one:

tell application (path to frontmost application as text)
end tell
1 Like

None of them working (HUD or the apple script as attached), in both cases the modifier keys settings are ignored regarding less the key (tried also with ⇧, failed too).

If I just copy the original content of the Touch Bar Button Group out of the group directly into the Global Section, they appear and disappear perfectly.

Sorry, I didn't realize you where using it in a group.
Could you try whether 2.697 (just uploaded) fixes this for you?

1 Like

Winner of a virtual beer! :smiley:
Perfect, thank you!!

Honestly, thank you. This really drove me nuts :smiley: And compliments for the great job you do, the program itself is already awesome, but your support is exemplary :+1:t3: