Show MacOS Control Strip disabled

:large_orange_diamond: To completely disable the system Touch Bar uncheck "Show macOS Control Strip" on the top. Then only the BTT Touch Bar will be shown. This will also get rid of the "X button" on the left side.

This is not so. As soon as I switch application I'm getting back the MacOS Strip and the "X button" on the left side.

maybe you have set an app-specific override for that app? (using the app-specific button on the left bottom of the BetterTouchTool preferences window)

No. I only have Global buttons. If check and uncheck "Show macOS Control Strip" the macOS Control Strip and macOS Control Strip go away but as soon as I switch to any other application, both come back.

mh I have never seen that before unfortunately.
What Touchbar settings do you have enabled in System Preferences -> keyboard?

App Controls With Control Strip

Ah wait, do you actually have any Touch Bar buttons configured in BTT? (Otherwise BTT won't show anything)

Of course I do...:slight_smile:

Hi there,
Did you fix your issue? I actually have the same problem myself.

As soon as I am in another app the app control Touch Bar shows up and my BBT config never shows unless I hit the "your BBT Touch Bar is hidden, click to show".

But when I do that, the X on the left appears.

Quite annoying....

I have the exact same issue. I disable the control strip and when I switch apps, it comes right back.
Turning it on and off again, it goes away. But then again, it comes right back when I switch to another app.

I checked all possible causes described here and in other threads, but no solution so far. Any suggestions?

I managed to fix this by making a new preset. I used the same buttons, widgets and settings as I used in the default preset, but now it just works. Might be an issue in the default settings? Or perhaps I missed something. Anyway, really glad it works now!

I'm having the same issue. What do you mean with making a new preset? Can you walk me through that?

Imprint | Privacy Policy