Show / Hide Specific Application stopped working for neovim-qt

Describe the bug
After updating to 3.071 (and later versions), the Show / Hide Specific Application action stopped working for neovim-qt. It works fine with other apps (like Terminal for example). Here's a compressed version of (931.1 KB) so you don't have to compile it yourself.

It worked fine with neovim-qt on older versions (unfortunately I can't say which unless BTT keeps some kind of update log).

After selecting the app and saving the action configuration, Saved App still says (null) (see the screenshot).

I already tried restarting the computer and removing & adding the action. I can reproduce this problem on two different machines.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Keyboard in general, it doesn't work with the previous generation of Apple Magic Keyboard as well as with Kinesis Advantage2.


Device information:

  • Type of Mac: MacBook Pro (Retina, 13-inch, Mid 2014)
  • macOS version: 10.14.5
  • BetterTouchTool version: 3.071, 3.086

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Unfortunately none.

Would you be able to add a bundle identifier to the info.plist? Every macOS app should have one and it currently seems to be empty in your compiled version. I think this might be causing the issue.

However I'll look into this and check whether I can revert the change that causes this to be an issue (made some changes there to fix issues with other apps...)

After adding the bundle identifier, the bundle identifier appears under "Actions Assigned to Selected Trigger", but Saved App stil says (null) and the shortcut still doesn't work.

I made the change to info.plist so that the bundle identifier key looks like this:


I can confirm that it works again in 3.097 after I updated the path to the app in BTT's configuration. Thanks!