Shortcuts in Context Menu

Hi,
I just created a context menu to select my shortcuts, but I have some issues with it.
The menu appears how it should, but it seems I can not select the shortcuts with the cursor.
And when I click outside the menu, it does not disappear. I have to hit the Esc-key.
And it only shows up in finder and the BTT app.
Do I do something wrong?
Thanks

weird, which macos version are you currently on?
Oh and what type of trigger are you using to show the menu?

I'm on macOS Monterey. Otherwise, I couldn't use Shortcuts. :sweat_smile:
And those are my settings:

I mean the exact version :grinning: (12.0.1 fixed many things)

Ah ok.
I'm on 12.0.1 and didn't update it since. so 12.0.1 was the final version.

Ok, I changed the touch gesture, and I can now show the menu everywhere. But I'm still not able to click anything with the mouse.

very weird, it’s a standard macos context menu - I’ll try to reproduce this on my other machines tomorrow

I was able to reproduce the issue on one of my intel machines, and I think I understand what caused it.
This should be fixed in 3.622!

1 Like

Wow, that was fast. Thanks for the update. Now it works how it should.
Thanks

I have one more question. Is there a way to have a custom order of the shortcuts folders?
In this case, I want to have the folders how I write them in the text filled on the BTT window.
But it doesn't matter in which order you write it in.
Can you have an order, or is it not supported?

This is not yet possible, but good idea!

Currently you might be able to change the order by ordering the folders differently in the Shortcuts app. (It might however display them in reverse order in BTT at the moment)

Yeah, I checked it, and as you can see, the order is not the same in the shortcuts app.
I also tried and changed the order in the shortcuts app, but like you already said, it didn't change it in the menu. It would be nice thou.
What also would be nice is to see the same symbols on the menu, as you can see in the shortcuts app.
Screenshot 2021-11-12 um 9.30.23 AM

Unfortunately shortcuts doesn't provide a way to get these icons, however you can specify them manually in BTT like this:

Adobe||paintbrush
Mac||laptopcomputer

( SF Symbols Reference)

1 Like

Ok, I see.
That works too for me.
Thank you for that.

3.623 now also keeps the order you entered!

1 Like

That is awesome.
Thank you very much.

Hey Andreas,
Sorry, it's me again. Unfortunately, I found another Bug.
It seems you no longer can change the order of your shortcuts by moving them in the shortcuts app.
Before the update, I could move them in the shortcuts app how I wanted them, and it transferred to the context menu.
But this is no longer possible.

unfortunately the shortcuts app does not guarantee any order, the code for this has not changed, but the shortcuts app returns them in a undefined order. I could offer to sort them alphabetically if that would help you.

possibly restarting BTT can help (because it does not reload the shortcuts every time because this is a cpu intensive task)

hm…too bad.
And to restart BTT was the first thing I tried.
And how can I order them alphabetically? I couldn't find any way to sort them.

Imprint | Privacy Policy