Shortcuts permission dialog

Hi, since I upgraded to macOS Monterey 12.4 on my MacBook Air M1 I cannot get rid of the access request dialog asking me to grant access to control Shortcuts Regardless what I'm clicking deny (Nicht erlauben) or OK, nothing happens and the dialog just stays there. I have not found any way to get it away. Only solution is to uninstall BTT and restart - which is not a good solution of course.
Do you have any idea what can be wrong? Is it something with BTT or with macOS?
Best regards, Norbert

maybe try to delete it manually from the automations list in system preferences-> security & privacy-> privacy-> automations

No, it does not help.
I can check or uncheck the box, but the dialog stays.

And after a restart the checkbox is always unchecked.

in that case most likely your macOS permissions database got corrupted. You can try to reset it using this terminal command:

sudo tccutil reset All

Quit BTT before running this, also save any unsaved work as this sometimes will require a system restart.

However after running this, ALL permissions will have been reset, so you will need to grant screen recording etc. to various apps again

Same question. Have you solved it?

I've also been experiencing this issue since updating to macOS 12.4

Tried @Andreas_Hegenberg's suggestions above including deleting it manually from Automations in System Preferences, as well as resetting the permissions database with sudo tccutil reset All, but the result is the same. Also tried removing BTT completely and re-installing it, but no dice.

Have had to uninstall the app for now. Anything else we can try?

Thank you!

Unfortunately the suggestion did not solve the issue.
But in the meantime I'm facing the issue also with other applications and also on another Mac.
Seems to be a combination of an app and macOS, as I cannot imagine that my permissions database got corrupted on both machines at nearly the same time (and I'm using them differently). I have the impression that the order in which these permission messages pop up and the order you answer them has an impact. After a reset of the permissions and a reboot, I could solve the issues with all apps except for BTT, by rebooting a few times and in each cycle adjusting one setting (e.g. iMessages asking for sharing my focus; another app asking for access to the calendar). Strange is also that on one Mac BTT is asking for access in Automations for Shortcuts and, while on the second only for Shortcuts

I've just tried installing a fresh copy of BetterTouchTool, on a clean install of macOS 12.4, on a new machine (14" M1 Pro, if that helps) – and still having the same issue.

did you download BTT from It is important it's the original version signed by me.

@Andreas_Hegenberg Yes, got it from "Download Latest" on specifically.

I have also noticed afterwards while setting up this new machine, that other apps (such as Zoom) have a similar issue with the permissions dialog – as folks mentioned above. Those ones I could close by hitting "esc" and then setting the permission manually in System Preferences. But BTT is the only one that just won't go away :thinking:

I can say for sure that it works on almost all systems (>99,9% of installations), but I have no idea what causes this failure on some systems. It is a macOS bug, but what causes it, especially on new installations is a mystery ;-(

Is maybe system integrity protection disabled on your Mac? You can check with this terminal command:

csrutil status

Strange! And just checked, it looks like System Integrity Protection is enabled on both computers.

I updated macOS to 12.5 and it solved the problem.

This has also just been resolved for me on both machines after updating to macOS 12.5.

Thanks all!

yes, updating to macOS 12.5 solved it also for me