Shortcut integration runs into internal error

Siri shortcuts integration fails after the most recent version update 4.462. Regardless of the function the shortcut app returns an internal error.

Screenshot 2024-03-24 at 09.50.53

Macbook Pro 14", 2021 running MacOS 14.0 (23A344)
BBT 4.462

Weird, that action still seems to work fine here. Does BTT crash / restart if you run this?

I'd not recommend to stay on 14.0 since Apple has changed/fixed various things about shortcuts and also about clipboard handling since that version.

Thanks for the heads-up, I'll update the OS tonight. BTT doesn't crash when running the shortcut, however I've tried using other BTT commands such as sleep display and they don't seem to run either. The errror message is the same.

In that case, maybe try to restart your Mac. I think "internal error" usually means an error inside the shortcuts process occured.

That was the second thing I tried after quitting and relaunching BTT, but sadly to no avail. The error started occurring after updating to BTT version 4.462 this morning, I've never had any issues with my shortcuts before that.

Unfortunately I can't reproduce it on my machines right now. Maybe it's a macOS 14.0 issue, but I'll keep monitoring this in case it's related to something else.

AFAIK shortcuts updates its app cache when adding / removing an app from the Applications folder. Possibly try to delete BTT from applications and download a fresh copy from

Apologies for the delay, but the update to MacOS14.4.1 did indeed resolve the issue