Shift+scroll triggers tilt-wheel button actions instead of scrolling horizontally


#1

Describe the bug
Logitech tilt-wheel buttons (push left, push right) show up as customisable buttons in Better Touch Tool. In macOS Sierra and earlier this worked as expected, and holding shift while scrolling the wheel would then scroll horizontally (depending on the app, Photoshop of course breaks this because, well, Adobe...but for the most part it was reliable). In MacOS High Sierra, holding down shift while scrolling the wheel up and down now triggers any actions attached to the left/right tilt buttons. This is not expected behaviour, and breaks functionality.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Logitech G700 tilt-wheel buttons and scroll-wheel action (based on the number of users reporting the same bug on the previous support forum, it doesn't sound like this is limited to just one model of mouse).

Screenshots
No screenshots.

Device information:

  • Type of Mac: 2013 Mac Pro 12-core, 2015 iMac 4-core i7
  • macOS version: High Sierra 10.13.6 (and previous versions of High Sierra)
  • BetterTouchTool version: 2.660 (and previous versions of BTT)
    (this has been a long standing bug reported by many users over the past year)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
User neonbaer has recommended that I use Smooze instead of BTT in order to customise the scroll wheel actions without interfering with horizontal scrolling using shift+scroll. So...right now, the workaround is to not use Better Touch Tool.

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

I have been using Better Touch Tool for many years, and use it on 4 different systems. This bug was reported in February of 2018, and closed without ever being addressed.