shift modifier with keyboard special key not working

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool
and that you have already tried to restart your system :-).
:ballot_box_with_check: I'll restart right now, I swear. I just didn't want to lose my draft here with screenshots. will update to confirm it persists.
If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

I'm using a keyboard with dedicated media buttons including vol up/down/mute.
my volUP key has been broken for several years and I've had SHIFT+volDN mapped to volUP

I just updated this system from 13.6.x to 14.4.1, and that shortcut broke. The shift key went away from the existing shortcut. re-recording the shortcut gives the same. Using shift with F keys or any other keys works as expected.
I updated to latest alpha with no change.
verified PPPC settings (NOT in input monitoring, removed and re-added to Accessibility.)
I toggled the "higher level modifier key recognition" as well without change.
Watching the advanced actions config output I see the shift key presses as 56 & 60, but don't see the media key presses.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

keyboard is a Microsoft Natural Ergonomic 4000 1.0

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

recording a shortcut shift-N shows the expected up arrow

using shift-volDN gives the EXACT same as just volDN. The modifier isn't registered. other modifier keys don't register along with volume keys either.

Device information:

  • Type of Mac: imacpro1,1
  • macOS version: 14.4.1
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

44660, as well as the most recent release channel. sorry, didn't note that one
Additional information (e.g. crash logs, related issues, etc.):

no different after full computer restart.

Still can't capture modifier keys alongside those media keys.