Several Actions No Longer Working on Sonoma Beta

Send Shortcut to Specific App, Close Window (works in Misssion Control), Quit App, Minimize App and w others. I have been using workarrounds tto preform actions via applescipt or just plain shortcut ie command+Q

Any fixes would be appreciated.

On latest alpha with Macbook running Sonoma Beta

I plan to use the next beta as my main driver, then fixes will come quickly.

For now, make sure any permissions are given in System Settings => Privacy & Security => Automations:

Possibly Sonoma got stricter permissions (again)

I thought this new alpha version 4.188 would fix the many bugs on sonoma beta. Sadly I'm still having show/hide specific application issues (lots of triggers using it).

Any update on this issue?

Why would you think that? The alpha doesn't mention any Sonoma related things.

However this seems to work fine here :thinking:
The actions you mentioned @wynstaxxx also seem to work fine here, was this maybe fixed with Sonoma beta 6?

You mentioned planning to use the next beta, 2 days before sonoma beta 6 release, and fixes would be quick, then a btt alpha was released 2 days after sonoma 6.

Anyways I'm still having issues:

The problem seems to be with 'last used window' option. When I select 'All windows', the Show/Hide specific application action works.

Also, when using the action 'Activate specific window', I'm unable to paste anything on that activated window (type via paste or the command+v shortcut) .

makes sense, not that quickly though :slight_smile:

I'll check again whether I can reproduce this!

for example you are saying you can get any of the following working?

  1. minimize window under cursor
    2.close window " " "
  2. hide app " " "

there are others but I just tried those again and no luck. I can do them via workaround appllescriipt or shortcut but I think there must been some changes(?) in sonoma and subsequently a variety scripts no long function


Yes, I tried all of them and they work without any issue here.

Possibly try to remove BTT from System Settings => Privacy & Security => Accessibility, and then add it back manually again. Could be some permission issue.

Wanted to check back and say thanks. I ended up reinstalling BTT and works! All the one so far II have checked are now back working. Tried redoing the permissions but that didnt work,....the clean install is what did it.

Thanks for help

1 Like

thanks for reporting back! I hope this won't be a thing that occurs often with Sonoma, but sounds similar to issues that always happen when upgrading to newer macOS versions ... probably something got blacklisted or some code signature change or....

I upgrade to Sonoma this morning and find out two issues:

  1. On my menu bar, it says “Bettetouchtool is capturing your screen.”
  2. After I reboot, Sonoma says “you cannot open Bettertouchtool because it is broken or incomplete”

I am using MacBook Air M2.

various BTT actions like the window switcher capture the screen. If you have the Notchbar functionality enabled, that will also capture parts of the screen (specifically the status items).

About the broken BTT: most likely something corrupted your installation, try downloading a fresh copy