Sending keyboard shortcuts under multiple input methods - Bug or by design

Hi
I've noticed something rather annoying with BTT.
Whenever triggering a keyboard shortcut when the current language is not english, BTT will attempt to send it using the current keyboard layout which obviously won't work. Only remedy is to change the layout back to english and retry.
I've also noticed that when opening the GUI when the language is not english, the GUI would display the current language's equivalent.
I don't see the use of it and was wondering if there is, and if not is there a way to force the trigger to be consistent with the initial setting?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard

Screenshots


Device information:

  • Type of Mac:MBP 2015
  • macOS version: High Sierra 10.13.6
  • BetterTouchTool version: 3.2.06

Unfortunately that's due the way the macOS standard key handling api's work by default (they give the physical location of the key, not the character <> key mapping.

You can try the "auto adapt" option to workaround this, then BTT will try to send the shortcuts based on the character.

Thanks for the quick reply :slight_smile:
I've tried playing with the auto adapt option which helps with triggers initiated using a keyboard shortcut, But when sending a keyboard shortcut action using a trackpad gesture, ticking/unticking this option doesn't seem to help...

Mh, it should! Maybe some sort of bug.
Could you post an example that doesn't work? (Just select the trigger in BTT, cmd+c and then paste it here in the forum)

Sure :slight_smile:
Huh , that's odd, as I was pasting the trigger I noticed that in the displayed paste the BTTLayoutIndependentActionChar was with non english char, so I tried to set it again and still when pasted it displayed 'ר instead of r, only deleting the gesture completely and recreating help for this and other similiar gestures with the auto adjust layout unset..although I'm quite sure it was setup with english as the active keyboard
But there still one trigger that doesn't work, here it is..
[
{
"BTTTriggerType" : 103,
"BTTTriggerTypeDescription" : "3 Finger Swipe Down",
"BTTTriggerClass" : "BTTTriggerTypeTouchpadAll",
"BTTPredefinedActionType" : -1,
"BTTPredefinedActionName" : "No Action",
"BTTLayoutIndependentActionChar" : "a",
"BTTAutoAdaptActionToKeyboardLayout" : true,
"BTTShortcutToSend" : "0",
"BTTEnabled2" : 1,
"BTTAlternateModifierKeys" : 0,
"BTTUUID" : "738380B6-FD47-4ACB-BDDA-5DFF77445602",
"BTTNotesInsteadOfDescription" : 0,
"BTTEnabled" : 1,
"BTTModifierMode" : 0,
"BTTOrder" : 5,
"BTTDisplayOrder" : 0,
"BTTAdditionalActions" : [
{
"BTTTriggerType" : -1,
"BTTTriggerClass" : "BTTTriggerTypeTouchpadAll",
"BTTPredefinedActionType" : -1,
"BTTPredefinedActionName" : "No Action",
"BTTLayoutIndependentActionChar" : "a",
"BTTAutoAdaptActionToKeyboardLayout" : true,
"BTTShortcutToSend" : "0",
"BTTEnabled2" : 1,
"BTTAlternateModifierKeys" : 0,
"BTTUUID" : "C1DFA58D-0AD3-4EE7-B4A6-EEEEE9C3F6EC",
"BTTNotesInsteadOfDescription" : 0,
"BTTEnabled" : 1,
"BTTModifierMode" : 0,
"BTTOrder" : 36,
"BTTDisplayOrder" : 0
}
]
}
]

note Might be a side bug but you might notice that the trigger sends the letter A two times, which is because for some reason when setting an action that just sends "A", BTT won't display the action and won't send it unless I set it to send another "A". That's weird because it only happens with the letter A. (see video)
18
Edit: NM, cannot upload the video and the bug isn't related (I think) but if you want, just try to set a trigger that sends "A"
Edit2: Here's a link to the video https://imgur.com/a/zZ94YwH

I also noticed that BTTAutoAdaptActionToKeyboardLayout is pasted as true weather or not it is set in the GUI. In the trigger pasted above it is unset in the GUI

Whoops, Bump ?
I've tested a few of the triggers on the terminal to see what it outputs and it's definitely outputs the current active keyboard chars, instead english regardless of the Auto adapt option...

Sorry I'll need a few days to look into this, but it's on my list!