Send Keyboard Shortcut action does not work every now and then

Describe the bug
I have set up an action in the chrome browser that when I pull down with 3 fingers, it will show a HUD and run command + R to refresh the current page.
Usually it works, but occasionally it just stops working for no reason - the HUD works, but the hotkey is not sent. After a while he returns to work on his own.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Trackpad


Device information:

  • Type of Mac: MacBook Pro 14" 2021
  • macOS version: 14.1.1 (23B81)
  • BetterTouchTool version: 4.318 (43180) and too in version 4.329 (43291)

Additional information (e.g. crash logs, related issues, etc.):

I tried to script the screen while the bug is happening using CleanShot software which has an option to record keystrokes,
And it seems as if only a command was sent without the letter R...
video attached:

When the bug occurs, keyboard shortcut sending actions in the Visual Studio Code app also do not work.
I will be happy to provide any information needed

I can't think of any reason for this. The keyboard shortcut sending action is one of the oldest in BTT, there is no way BTT would only send the modifier key unless the other key is intercepted by something else inbetween.

Do you have any other keyboard / mouse related apps installed? (Either listed in System Settings => Privacy & Security => Accessibility or in System Settings => Privacy & Security => Input Monitoring)

Do you maybe have different keyboard layouts you switch between? (This could cause issues)

1 Like

Yup! I switch between a Hebrew layout and an English layout,
following what you wrote, I canceled "Auto adapt to current
keyboard layout", I saved and re-ticked (for each such send keys action), and it seems to have solved the problem