Right click not working when BTT runs

I have BTT 3.596. For some reason, when I "right click" on my track pad by just doing a normal two finger click, the Application switcher appears. It is as if I pressed Command + Tab. If I fully quit BTT, then the problem goes away.

I do have a BTT Trackpad shortcut for application switcher, but it is 5 finger tap. I have 4 finger tap set to "command + Tab" as well. I have disabled both and the problem still persists no matter what application I am using.

My 2-finger gestures all have nothing to do with the application switcher. Anybody know what is going on?

And strangely, while BTT is open, if I disable Secondary Click in Mac Preferences, the problem goes away.

I restarted and it did not help.

Same here. After updating to BTT 3.6 and macOS Monterey, right click seems to raise my volume.
Quitting BTT returns everything to normal.

you mostly have a right click configured in the normal mouse section in BTT :slight_smile:

In older versions these only worked with modifier keys assigned but that limitation has been liftet recently.

That solved it. I never use normal mouse settings, so I did not think to look there.

Thank you, yes that was the problem. I haven't used a mouse in years, so I'm not sure why that was there - probably an old setting I had, although I don't know why I would have assigned "Rightclick" to "Application Switcher."

Is there a way to turn off auto-update with BTT? That will help me correlate updates with bugs that coincide with updates.

yes you can disable auto update in the settings :slight_smile:

Thanks, I was blind. Its in BetterTouchTool, Preferences, Basic, and its one of the checkboxes at the top.

I will leave Enable automatic update checking enabled, but I will disable "Silently download and install updates on restart"