Right click drag on Mac?

I'm trying to have some action allow me to right click drag (need for chess.com) which allows one to draw arrows on the chess board using right click drag. I can right click of course and I am able to use BTT to initiate a mouse drag and stop it but it's a standard left click drag. How can I enable right click drag?

1 Like

I also need Start Right Drag and Stop Right Drag. I use OnShape and right drag is important. Normal right drag rotates the model and Ctrl right drag slews the model.

I know I can do right drag with two finger drag on the touchpad but it's awkward. It would be great to be able to quickly go in and out of right drag mode with keyboard shortcuts.

Curious! I know I can right click with 2 finger click but that won't allow me to drag. Are you using a Magic Trackpad? I've only the one builtin to the MBP.

Pressing down with two fingers and sliding them up/down & left/right does a right drag. It's a generalization of two finger right click. Of course just siding two fingers without pressing down does a scroll. I have a MBP but I know it also works on the Magic Trackpad.

1 Like

Very interesting. I'm not able to replicate it. Many people in StackExchange also say it's not possible on a Mac. Someone recommended doing the three finger tap drag with CTRL+CMD but that doesn't work either. Perhaps it's got something to do with the app I'm using it in? I'm using Safari and chess.com. I don't have anything else to test with so I'm assuming it's a problem doing it on the website perhaps. People mentioned that Xcode also uses right click drag for certain things. Perhaps, @Andreas_Hegenberg can shed some light on this.

There seems to be a bug that makes it intermittent. After messing with my trackpad settings - mainly the secondary click and force click options - two finger right drag stopped working in Firefox which I mostly use as my browser. It also didn't work in Safari. (I'm testing this in OnShape.com) However I changed my settings again and it started to work again in all browers including Safari, then I exited Safari and returned, and it stopped working there it also stopped working in Firefox. Then I played with the settings again leaving it set to"click or tap with two fingers" and this time it worked in Firefox but not Safari. I can't find a pattern to what triggers the bug. Running Safari, possibly also doing a two finger drag in Safari may be a related, but I'm not sure.

However I'm certain that two finger press/drag should do right drag when you are in "click or tap with two fingers" mode, other than this bug. Two finger press/drag also works in Microsoft Excel where right drag gives a menu at the end of the drag to do a choose the type of copy to do. (I know this because at one time I worked at Microsoft on the design of Excel.)

Here is a way that should almost certainly work for you: In trackpad settings set secondary click to be "click in the bottom right corner". Now if you press the bottom right corner with one finger and drag with another finger it does a right drag. This works even if the two finger right drag bug is happening.

I started a new post here as it seemed sufficiently different, but have any of you found a way to drag with the middle button or multiple buttons on either the MBP touchpad or the MagicMouse?

Thanks

Imprint | Privacy Policy