restarting btt takes too much time.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

After wake up, trackpad and keyboard freeze within few minutes.
So I installed carabiner and move all keyboard shortcuts from btt to carabiner.
In btt, there is only trackpad tip tap motion.

after some wake up, freezing happens again with trackpad, not keyboard.

So I try restart btt, but it takes 1,2 minutes. It is too long. Is it normal?
After rebooting mac, restart btt takes 2 secs.
I don't know reason about freeze & long time restart.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: mac late 2014 5k
  • macOS version: 10.14.6
  • BetterTouchTool version: 3.202

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

On current versions BTT usually doesn't need to restart after sleep. Make sure the restart after sleep option is not active in your BTT settings.

the option is not active.
but sometimes when mac wake up, trackpad freeze few minutes .
so I check whether it is normal or not by restarting btt.
when it was normal, btt restarted immediately,
when it was abbormal, btt restarted few minutes.
So i have a question, restart time is not important? is it useless infomation?

In general it should only take a few seconds to restart.

Do you have Dropbox sync enabled in BTT? Some users were having issues with that - if you do, maybe try to deactive sync for now.

I am experiencing the same. Often (though not always) when my MacBook Pro 2015 wakes from sleep, for several seconds the BTT icon is not present in the menubar and my the OS doesn't respond to any clicks on my trackpad.

I have the restart BTT setting unchecked and am not using Dropbox - although I do use iCloud sync.