Requests to run AppleScript app from launch

Hello! Long time user. First time posting.

I am having issues with a Floating Menu item that should launch an AppleScript app.

I can double click on the app and it launches with no issues. The script simply does this ...

use AppleScript version "2.4" -- Yosemite (10.10) or later
use scripting additions

on run
	display dialog "Today is really great!"
end run

When I trigger to launch the script from the floating menu, I now get this dialog ...

I was not getting this dialog a few days ago. I've tested the script as a menu bar action (on my MacBook Pro), and it runs without the dialog.

I am using the test script solely as the simplest case. I have other, more complicated scripts that are not amenable to writing directly in the BTT script input window.

I have gone through all levels of the Privacy and Security settings to see whether I should toggle something, e.g. to give BTT permission to control the application. I cannot find anything. I've also restarted to no avail.

What am I missing?

Ventura 13.5.1


This is an option if you save the script in the editor as an app:
(Show Startup Screen)

PS: I have lots of Applescripts in combination with BTT and so far I haven't had to outsource any as an app. You can also use script libraries, for example.

Unfortunately, making this change does not change the behavior. I still get the dialog box. I changed the script to a different text phrase and I restarted BTT to be sure.

Also, the issue has arisen just recently with script apps that did not have the issue as early as the start of the week. I cannot imagine what I've done in the meantime to cause such an abrupt change. I've not changed any privacy or security settings, nor have I added any other extension.

FWIW, I am running the BTT version from SetApp, and I am coding in Script Debugger.


maybe your app file is not actually getting overridden? I‘d try deleting the old copy before saving a new one.

I‘d assume this is not really related to BTT, or does it not happen when launching the app via Finder?

Very strange. I also develop with the Script Debugger and the (exact same) dialog only appears when I have activated "Show Startup Screen". :thinking:

I deleted the old file and made a new file. The dialog does not appear when I double click from the Finder. The dialog also does not appear when I launch the script app via my MBP menu bar.

Yes, very strange indeed. I am still testing a few other options.


are you sure BTT is actually launching that app? (maybe try deleting it and see what happens when you try to launch it via BTT then)

I can‘t think of a reason why it would behave differently when started from BTT :-/

So, some further information.

I used tccutil to reset security permissions and rebooted. No luck.

I had the Floating Menu set to appear at the Finder level when I select the SHIFT+CONTROL keys. This worked. After the above reboot, I restarted BTT. I decided to turn off the keystroke toggle. The Floating Menu appears directly when I am at the Finder. In this case, I can launch the without the confirmation dialog.

My thought is that something in holding SHIFT+CONTROL to show the floating menu causes the script launch to put up the extra dialog. Unfortunately, I now cannot return to a case where I can have the floating menu appear only when I hold the modifier keys. I am apparently not resetting the preferences for the floating menu properly to reset this behavior.

Also, in the meantime, I had quit Keyboard Maestro just to assure that it was not capturing or adding keystrokes to the process. But this seems not to be a concern.


If you open any applescript via any shortcut that contains the "Control" key, you will always get the dialog asking run or quit.

The solution is to never use Ctrl key to open any applescript.

oh wow, there is always something new to learn:-)

maybe you can use the ctrl up action before and the ctrl down action after calling the script

I forgot to say that if you run an applescript holding the Ctrl key, the dialog appears.

So, in the case of a shortcut with control key, the dialog appears, but also running manually any applescript with ctrl key pressed shows the same dialog.

1 Like

This can be workedaround by using the "Run Apple Script" action with source type "scpt" file. However there was an issue saving / selecting scpt files in the current BTT version. This should be fixed 4.372 alpha /uploading now: