Release notes failing to render

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
For the last few versions for me, the release notes aren't rendering:

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Imgur: The magic of the Internet

Device information:

  • Type of Mac: M1 MBP
  • macOS version: 13.2.1
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 4.184

Additional information (e.g. crash logs, related issues, etc.):

do you maybe have a firewall blocking the request?

Same issue (for a while now)
I've never changed any firewall settings relating to BTT

I can replicate it with the current alpha release if needed to bugtrack @Andreas_Hegenberg

can you post a screenshot of how it looks like? Does it show the update window but no release notes?

From the screenshot posted in the initial post, I think BTT believes the update should be automatically installed (the checkbox to automatically install updates is active), but for some reason it is not being installed automatically and instead shows the release window.

The text just doesn't load...

I think this should be fixed with the new alpha. Probably caused by a certain combination of settings.

I'll let you know. Can't tell before the first new alpha after version 4.196!

1 Like

I have also been experiencing this issue for some time. I updated to the latest regular update this morning. I came here to the forum for another reason and saw this so I decided to update to the latest Alpha. Still no text in the box. I updated to the latest Alpha but there is no way to tell yet if this issue was addressed until another new Alpha becomes available. However, the other reason I came to the forum has continued with the current Alpha so I just went back to 4.184 (2403) for reasons not related to this specific issue.

Fixed as of at least a few minutes ago (2023-08-27 18:08 EDT) when I installed the 4.199 (2419) alpha.

Was this fix in the recent 2421 stable release? I guess I'll know for sure when the next stable release is out. It would be great to update to add release notes to the stable release notes web page too. It has not been updated since July 4th when I check and I can not see the updater release notes. I'd love to have new excuses to mess with BTT instead of working :wink:

Just saw there's an update!
Can confirm it's fixed coming from the previous alpha version!