Random Bugs in Touch-Bar Groups

Apple Macbook Pro (13-inch M1, 2020)
macOS: Big Sur v11.0.1
BTT: v 3.508 as well as 3.509 (1647)

I have created groups with items.
The “Show macOS Control Strip…” is checked.
I do have 5 icons to the right of the arrow (BBT Icon is one)
There is an “X” on the left of my BBT buttons as expected.
Some buttons are groups, some are Individual.

When I click on a group name, the buttons within the group show up with an “X” on the left. (As I expected).

BUT, after I click on an item within a group, one of these actions randomly happen:

  1. The menu reverts to the main BBT set of buttons .
  2. The items displayed within the group stay as is (see * below)
  3. The items displayed within the group stay as is AND THE “X” DISAPPEARS
  4. If the group had no items within it, an “X” appears on the left with black space after. But I cannot get back to the main BBT menu unless I restart the app.
  5. Once, when I restarted the app, BBT did not show up, only the Mac control strip.

*** These random events happen whether I have “Keep group open while switching apps” checked or not. Whenever I have checked or unchecked the box, I always press the “save” button. Sometimes I have also restarted BBT to see if that changes anything - which it does not.

  • When the items stay within the group and do not default back to the main view, clicking the “X” and then the BBT Icon twice does not bring back the main view, it brings back the same open group view (usually with the "X" on the left, but once without the "X" and only the item names). Only restarting BBT will reset everything.
  • I have the same settings for all groups, whatever the settings happen to be.

  • This happens randomly for all groups I have created

  • Single buttons not associated with groups do not have any issues.

  • There are no crashes associated with any of these events.

  • I have tried this with BTT v 3.508 as well as 3.509 (1647). This happens for both.

  • I have tried restarting BBT as well as quitting it and opening it again.

  • My Mac is the new M1. I did not use a back up but started everything fresh. So my previous BBT files were never an issue.

  • Of course I have tried turning the computer off and on.

  • I do have BBT as a login item.

  • Perhaps there is some setting I haven’t figured out.