"Quit App Under Cursor" has stopped working sometime recently

Describe the bug
Quit App Under Cursor is currently non-functional for me.

It was definitely working for me a few days or a week ago, but now it does nothing.

I don't know if it's broken due to BTT updates or some change in my config, but I don't know what config could affect this?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

I believe all.

Confirmed with keyboard shortcut, and "Right click Red Window Button".

It's "right click red window button" that I actually want to use with this action, and I've had it configured for many years. I then set up the keyboard shortcut for additional testing, to rule out it being a problem with the right click red trigger.


Here's a short video demonstration of Close App Under Cursor doing nothing on Preview and Google Chrome: 2023-03-09_15-45-51

Same applies to all other apps I've tested with.

Device information:

  • Type of Mac: Hackintosh MacPro 7,1
  • macOS version: 13.2.1
  • BetterTouchTool version: 4.065 (2281)

Same applied to the version that was out before 4.065 - I forget the version number now - and maybe the one before that. I'm not 100% sure when it stopped working.

Seems to be working again now in 4.067

I don't think there has been a change :man_shrugging:

Ahh OK, yeah it's broken again.

I specifically tested it moments before applying the 4.067 update to confirm it was still a problem, and then immediately after applying the update at which point it started working.

After seeing your message just now I confirmed it was still working, then restarted BTT from the menu bar icon, and then it stopped working. And still broken now, after a couple more BTT restarts.

Between when I first reported the issue and today I have rebooted a few times, and each time the bug remained after the restart. It was just that one time I restarted BTT to apply 4.067 that it then suddenly started working, only to then break again on the next BTT restart.

So yeah, still a problem.

The code for this action hasn't changed in many years. It's only a few lines of code and I'm not sure what could cause problems here. Maybe if some other app has overlayed your screen with an invisible window, then BTT wouldn't be able to get the correct window anymore.

I think some screen recording / drawing apps have been doing this in the past.

Huh, OK. I do certainly have lots of apps that can record the screen and have accessibility access. And I've updated several of them recently.

But I've tried closing them all, at a time when Close App Under Cursor isn't working, and it doesn't make it start working.

Also, sometimes restarting BTT is all that's needed to make it work or stop working. Like right now it had been working since boot - with all those screen recordy apps running as normal - then I restarted BTT and then it stopped working instantly. And the same has happened in reverse, eg when I installed the 4.067 update and it started working, having not worked for several days before that.

Is there any way we can debug this?

I don't know if it's relevant, but other functions are working that I would have thought would also need to find the correct app windows. For example I recently installed SWM, and that's working fine when left clicking the yellow button:

If I click one of those window management buttons, it moves the right window the appropriate place. So BTT window management seems to be fine in general.

I also am having this problem, strangely enough. Pretty much all of this is identical to how things are going for me, though I haven't really had much luck with restarting BTT fixing the problem though. Very strange!

1 Like

Glad to hear I'm not the only one!

For me it does vary. Yesterday it wasn't working all day, but when I booted up my system this morning it was working fine. So I did a test restart of BTT, and then it stopped working again.

I can't find any other BTT features that aren't working, it just seems to be this one.

If it is related to other apps, like ones that use screen recording, or my tablet app, then I can't figure out which one as closing them all makes no difference, and the only thing that does ever seem to vary it is restarting BTT. I can't see that there could be an invisible window displayed over other windows because surely that would affect many other features as well, both in BTT and in other apps?

For example SnagIt's screenshot tool detects the outline of windows, and even panes within windows, and that's working fine. And closing SnagIt doesn't make any difference with regards to this bug.

1 Like

I do have a more robust way of getting the window, I can activate it for this action as well - maybe that will help (although it would be interesting to know what causes this)

1 Like

Thanks Andreas!

Just to add that I just checked the BTT logs and there's nothing logged as I try the Quit App Under Cursor action, either via Right Click Red Button, or keyboard shortcut.

I did see this message printed a few times in different spots:

1678870478.802803|WISNA|Focus doesn't match window pid|

But it doesn't correlate to my trying the affected action.

1 Like

Did the fix get into 4.070? If so, it's not worked - same issue still applies in 4.070 (2285)

yep, if that doesn't work I don't see any other way to get the window :-/ I believe something is interfering then because this method has been robust for many years