Process not detected by conditional activation group

Describe the bug
I own a process called "Barre" but it is not detected by aditional activation group. Nothing happens when I enable 3 Finger swipe down

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook Air

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook air
  • macOS version: 10.13.6
  • BetterTouchTool version: 2.6

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

This app probably doesn't trigger a "context switch" when it becomes active, therefore BTT won't be notified when it becomes active.

What kind of app is this?

I tried with many processname : Safari, Finder : same problem except with BetterTouchTool :slight_smile:

Weird this should work fine.
Just in case there is a misunderstanding: The gestures/triggers will only be activated if the process is the front-most one. So if you configure it to match Safari, it will only activate them when Safari is front most.

ok it works If Safari's window is selected.

So if application (Barre, Bartender, etc.) is a "menu extra app" without window, how BTT can detect it ?

It currently can't unless the app makes itself the active process :slight_smile:

I could add window title observation for the system ui, but currently I think this would cost too much performance.

The process matching function is mostly useful for java apps etc. which are otherwise hard to configure in BTT.

ok I understand


Do you think BTT can detect more type of triggers, such as SSID ?

Yes future versions will add more triggers :wink: