Problem with shell script and clipboard since latest update

I have defined a keyboard shortcut, that has 2 actions. The first action calls a bash script. This script uses the pbcopy shell command to copy some text into the clipboard. The second action is "Send Keyboard Shortcut command-V".
This worked until the latest update. Now it pastes whatever is currently in the clipboard. Looks to me as if the contents of the clipboard are restored after running the shell script. I verified that the script is copying the right content if I run it from Terminal.
Is this a bug? Or did you change it on purpose? If the latter, could you please give me a tip what to change so it works again?
Thanks, vtd

which exact version are you currently on?

Sorry, it is 4.492. Running on macOS 14.4.1.

could you try upgrading to 4.504? I haven't pushed out the new builds to all users because this probably won't affect many. I think this should be resolved already

Sure, I will try.

I am now on 4.504. I also quitted BTT and started it again, but it didn't resolve my problem.