Problem in Opt Key Up Action

Was posted originally as a bug report. However, no reply received. Considering this action to be quite common, I think the problem is in my understanding, rather than a bug.

Initial Details

Running alpha version (11.5.2) , Tried restarting computer, no crash, hence no log to show


Gesture: 4 finger swipe down, other gestures also tried to no effect.
Actions: Opt Key Down, Opt Key Up.
The actions are not the final intended actions for the macro, but are reduced to simplify the bug and its explanation. From my understanding, the 'Opt Key Down' action will hold down the the Opt Key (even after the macro terminates) until the 'Opt Key Up' action is activated. Now, on setting only the 'Opt Key Down' action to the gesture, this works as expected, because the opt key is still held down, which can be seen through different characters on typing. Now, after both of the above actions are assigned to the gestures, I expect that the 'Opt Key' should not be held down. However, the 'Opt Key' is still held down, which can again be seen through keyboard input.

Affected input device

MacBook Trackpad

Device information:

  • Type of Mac: MacBook Air (Intel-Early 2020)
  • macOS version: Big Sur (11.5.2)
  • BetterTouchTool version: 3.581

Additional information:

This also seems to be the case with other modifier actions, like Cmd.

On further investigation, it seems the problem doesn't lie in bettertouchtool itself, but rather due to some conflict between bettertouchtool and the window manager app 'Contexts'. Somehow, the problem persists even after contexts is quit and bettertouchtool restarted.

Thus, I realize. this becomes a niche request, but contexts is slowly growing in popularity, so I guess this might be useful some day.