presets can’t be imported.What should I do?

I downloaded and imported a preset, but there’s nothing in my settings. I can only add a new preset. What should I do?

yeah having the same problem too.
cant count how many times i had to create a new config over the last couple of years, because the freaking import wasn't working in the next Version.
this is the most annoying thing with BTT and seems to be still not solved ?! or is it now solved for good?! or if i again create a new config, do i need to do this again in a year ?! or do you have finally a core that you don't change again in a few months ?!

this whole topic is just freaking annoying and should not happens on a paid product! just like i think your support, again, for a paid product, is really bad, if you don't took a second to answer @jevolk
All in all btt is great, but things like this makes it almost impossible to use. who has the time to create a new config over and over again ?! pretty pissed to be honest

In general BTT has backwards compatible import until the first version ever released, > 10 years ago. (But of course it's not possible to import presets created with newer BTT versions into older BTT versions).

If you run into any issue with importing a preset, please send it to then I can have a look!

simply not true ... or at least completely buggy.
i, aswell as my collegue having the exact same problem with different configs multiple times, since we using btt 10 years ago .. it's working for the same version, but too often not for a new one

and still having that problems ... it's simply not possible to import different configs from the last couple of years ... there is no backwards compatibility - or at least extremely buggy

try it yourself (16.2 KB)

In the latest versions the import of old exports (done with versions that didn't have the JSON export yet, i.e. before 2018) is disabled by default for security reasons. If you want to import such, quit BTT and run this terminal command:

defaults write com.hegenberg.BetterTouchTool BTTDoOldImport YES

Afterwards you will be able to import them using the BTT UI. (Disable it again afterwards)

okay, that worked. thank you