Possible to remove the "X" / "Close BTT" button on custom TouchBar setups?

Hey, all, I'm sorry if this is obvious, but I'm not sure how to find out. Is it possible to remove the "X" on the left side of custom BTT Touch Bar setups? For example, I have BTT set for one app and the ESC key at the left side is moved over from the default in standard TouchBar apps. I'm always hitting the "X" now instead of ESC because it's not in the default position.

Photos of what I mean (sorry if I'm not describing it well). First photo is "default" Touch Bar position of Esc key... second photo is inside a custom setup with BTT.

The x is just another button. Usually called Close Group. Just look for it in your list of buttons/widgets and disable, move or delete it.
If you're having trouble finding it, feel free to post a screenshot of your BTT preset list and we'll try point it out.

Thank you for the information!

I am indeed having trouble finding the "Close Group" button/widget. I've included a screenshot below. Can you let me know where it's normally found? Thanks in advance!

Since it’s not in the app specific one. Have a look under global. It’s possible there’s one there that’s set to always visible.
Check any Close Group buttons for this and make sure they aren't checked. If you can't find one under global check all other apps, including inside any groups.

Thank you for the info. I don't see anything that says "Close Group" in any of the Touch Bar menus in BTT. Screenshots below. I'm stumped...

Looks like it could be a bug. Have you tried removing you preset and putting it back on?
i.e. Export your preset under Manage Presets, delete it and then import it again?

Alternatively, export the preset (including settings) and post it here (make sure you have no personal info in there though). I can take a look and see if it comes up on my touchbar.

Thank you, Doa. I created a new profile, deleted the old one and imported it again, and it still shows.

Also tried creating a new profile, added Parallels. The default Touch Bar behavior shows (Function Keys) when I don't customize the settings for the program. When I add, say, F1 to the custom Touch Bar buttons, it shows the X with F1 next to it. Can't find where that darn X is coming from.

Original settings file attached here. I'm fairly certain it doesn't contain personal info. Default.bttpreset (13.8 KB)

Just to make sure I've set it up the same, is your system preferences/keyboard set as

and in BTT general touch bar settings:

Let me know if anything is different.

Ok. It looks like the close group is part of the control strip, not BTT. It looks like BTT itself is being shown as an expanded section of the control strip.
Which means, you won't be able to get rid of it, so long as you have the control strip showing.


This ‘X’ button is part of the system control strip which MacOS Requires you to have if BTT shows the control strip. It’s just the way it’s implemented.

You can try unchecking “Show MacOS Control Strip” in “General TouchBar Settings” to remove this button, but unfortunately you will loose the control strip. (you might want to make a toggle BTT touchbar button)

I’ve achieved a way to remove the X and preserve the control strip in my preset, but currently BTT is not importing it correctly so i guess I can’t share it just yet... (sad)

Basically it’s BTT using full bar mode while an exact remake of the macOS control strip appears. So when the BTT preset is activated there is no X and the control strip remains.

See the preset here:
(currently working to fix the new version which is more relevant to you though, as i’ve only implemented the ‘no X control strip’ in version 2.)

[images coming in an edit]