Only one action "Cmd+C" is executed when multiple specified

Note: Before bug reporting, please make sure you hcave tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

I tried to run "Cmd+C" multiple times in cells of an Excel file via one single keyboard shortcut via BTT, so that I can copy multiple cells at one time.
This is how my trigger looks like.
But after executing it, it can only copy one of the cells, most of the time the last one.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook keyboard

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro
  • macOS version: macOS 11.5.2 (Big Sur)
  • BetterTouchTool version: 3.570 (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
none

Most of the time, or all of the time ?

I'd be surprised if it weren't only copying the last cell.

If I manually carry out the actions as shown in the screenshot (i.e. press C, then press , and repeat), the contents of my clipboard is the contents of the last cell at which I hit C. This makes sense to me, as that keyboard shortcut is tied to the menu Edit > Copy, which sets the clipboard to the current selection, replacing the clipboard's previous contents.

Is that different to how things work on your Mac ?

Actually all of the time. Sorry I was not clear enough on it.

I also uses BTT clipboard which can record all previous copies.
If we follow what you did manually, we would only have the last copy in system clipboard. But we can see all of the previous copies in BTT clipboard.
But if we follow what I did via BTT actions which follow the same steps, we can only see the last copy in BTT clipboard. That's the issue.

I expect after executing the BTT actions, we can see all previous copies in BTT clipboard too.

Regards,
cartern

Ah, this isn’t what you said originally, but now it makes perfect sense. Thanks.

Imprint | Privacy Policy