Occasional Frozen Keyboard

Hi. I'm running BTT 3.5.60 1700 on MacOS 11.2.2.

Occasionally—about 3 times a week—my keyboard (the external one and the one physically on my MacBook Pro) stops responding to keypresses. I don't know why, but quitting (or just choosing to re-start BTT) immediately resolves the problem. The computer is not frozen. Everything is responsive and the mouse works just fine; it's as though the keyboard is just frozen.

I can't say for sure BTT is the issue but wanted to post here to see if any one else has encountered anything similar.

Thanks for any guidance.

-- Robert

I have experienced the same issue. Although the frequency is not as extreme. I hadn't considered quitting and relaunching BTT as a solution. I restarted and it solved itself. I am going to try the quitting and relaunching of BTT the next time it happens.
The behavior started when I started using BTT, but don't know whether that is the culprit.


I have had the same problem - all of a sudden, maybe once a week, the keyboard stops communicating the keystrokes to whatever app I am in. The first time it happened, I tried closing various apps in turn, and found that closing BTT solved the problem. I now know that I simply have to close BTT but I hope that that glitch can be fixed some time soon.

Well, good to know I'm not alone. Thanks for the comments, @paul_alvechurch and @macosxguru.

@Andreas_Hegenberg, what's the best way to submit this as a potential bug report? I'm happy to provide any additional information you might need to verify and, if necessary, track down and resolve the issue.

-- Robert

Posting here is the best way. If you encounter this again, it would be great if you'd go to Help => Export Diagnostic Debug information and send the result to andreas@folivora.ai

Did it maybe happen after recording a keyboard shortcut in BTT?

1 Like

I don't recall that these occurrences were after recording a keyboard shortcut, but they absolutely could have been. Will keep a closer eye on that and will do the Export Diagnostic step next time. Thanks for the reply!

-- Robert

A clue, @Andreas_Hegenberg!

While working today I experienced the keyboard "freeze" described in this thread. I had NOT been recording a keyboard shortcut recently.

I happened to be working in Sublime Time. I wanted to type the number 2 into the buffer. When I pressed the "2" key, though, my Sublime Text screen split into two panes. When I pressed the 3 key it split to 3 panes. It turns out that's a built-in shortcut for Sublime Text. It equates to command-alt-2 and command-alt-3, respectively.

So, the keyboard isn't frozen. For some reason it believes the command and alt keys are pressed!

My keyboard is clean, so there are no keys sticking. I tried pressing those key combinations to "unstick" them, but it had no affect.

Restarting BTT, however, solved the issue.

Not saying that this is caused by BTT, but it's the nearest I've come so far to determining what's happening in these instances and wanted to pass it along.

-- Robert

I have this same issue, once a day, it does seem to be as my hand is passing over the keyboard, quickly typing away, and perhaps make an errant keystrike in the lower left corner, but it locks everything up and I have to restart BTT. Haven't been able to figure out what's triggering it.

Interesting. For me the issue has become far less frequent with these latest versions, though I’ve the handy “Relaunch BTT” keystroke memorized at this point. That always resolved it quickly.

@Chip, which version of BTT are you currently on?

Currently the latest build!

Interestingly, when I try to get the exact version number, I found the menu items to be unresponsive: