Now playing widget doesn't bring currently playing app to front

Describe the bug
Tapping on the now playing widget, when configured to bring the default player to front, does not bring the app to front. This seems to be a regression, because I feel like this bug has been fixed before.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.): Touch Bar

Device information:

  • Type of Mac: 15" MBP 2018
  • macOS version: 10.14.4 Beta
  • BetterTouchTool version: 2.702

Weird, this seems to work fine here.
Possibly try v2.703, maybe I accidentally fixed it already.

"An error occurred in retrieving update information." Update server down?

Sorry I quickly disabled it because there was a stupid bug in 2.703. Will be back in about an hour.

1 Like

Not working on 2.704 here. I have media playing in iTunes - not even in fullscreen or hidden, just not as the active window. Tapping the widget doesn't do anything. I've confirmed that the widget is set to bring the currently playing app to front, so it's not a configuration issue.

Someone in my office who uses my preset reported the issue to me, and I've been able to reproduce it, so it's definitely not just on my machine. The issue also happens on my 2016 MBP (which I still have).

That person is on the stable GC-BTT and BTT release, so 2.641 / 2.698 respectively, and is running the latest stable release of Mojave, so the issue goes back to at least BTT 2.698.

I just had a quick look (but at the experimental version of GC-BTT).
Unless this is an import bug, the tap action is set to bring the default player to front, but no default player is set. If you'd like to bring the currently playing player to front, you'd need to select this option:

Or alternatively assign an apple script like this:

tell application "BetterTouchTool"
	set playerBundleIdentifier to get_string_variable "BTTCurrentlyPlayingApp"
end tell

tell application id playerBundleIdentifier
end tell

That worked! Did this setting change in some version after 2.641? It seems like it is an import bug because this feature definitely used to work in my preset. But maybe I'm crazy...

Mhhh I don't remember any change but I may also be crazy :smiley:

:man_shrugging: welp, at least it's fixed lol. I'll push out a new experimental version with the change.