Notch Bar not showing 'Mini Menubar Area' nor 'Mini Status Icon Area' on "Standard Screens without Notch"

On M1 Macbook Air running MacOS 12.1, unless I'm missing something I can't get Notch Bar to show the original system menubar under the Notch Bar Widget and Notch Bar Menu bar Mode.

I've made sure to deselect 'Hide Mini Status Bar Container', etc. see attached image. Any ideas?

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

on normal screens without notch the menubar by default is only displayed when in menubar mode (switch between modes by scrolling up/down on the bar). It would be possible to display it below the other items, but it would need to be really small, that's why it's currently not included as a standard option.

Does it show nothing at all when switching to menubar mode?

The only requirement for this to work is BTT having permissions in system preferences-> security and privacy -> privacy -> accessibility.

Thank you for that clarification!

... When I enable 'Toggle mode by scrolling up/down' and then scroll up/down on the notch bar menubar the original system menubar shows up behind and overlapped with the notch bar menubar ... see image below.

Also, I did and do have the permissions correct in system preferences-> security and privacy -> privacy -> accessibility


Ah that's because you have unchecked the "hide left..." options for the menubar mode. For the default templates these are necessary to make the menubar mode worked as planned :slight_smile:

(But these templates can easily be changed, to do any custom layout, if you have some ideas you’d like to test)

Yay!! That was it! Thank you! ... one more question ...

Is it possible to have any opened app display it's icon when it's launched and hide itself when it's quit ... much like the dock or the menubar in Windows? I'm always looking for a way to combine the menubar and dock to save as much screen real-estate as possible. uBar has an approach but it creates a whole other bar whereas your Notch bar uses the same scree real estate as the original menubar.

I’m currently porting the old Touch Bar Dock widget for the Notch bar, that should be available in a few days. If you have any specific ideas about how it should look / work please let me know

Yay!! Oh wow, that sounds great. Thank you for your work! If I have any ideas on that I'll pass them your way.