Notch Bar development status

3.655 Should fix issues with the swish app!

1 Like

Awesome .and i see you said swish issue is now fixed.

I hope you'll keep mini menu-bar in external displays btw -even tho it makes less sense-as I'm sure many won't mind the slight loss of real estate lol

Also have you thought about making the notch bar behave like the touchbar? Depending on the content,the notchbar shall display words (if you're typing text),sliders (if youre using Photoshop) , basically behave like the real touchbar lol.therr is something like that in xcode (allowing the touchbar on non-toubar devices )

And again,thanks for everything you're making ,btt and the way you develop truly makes me wanna study development .and that's a compliment :slight_smile:

Unfortunately it's not possible for third party apps like BTT to efficiently figure out what exactly you are doing, thus these context aware things are hard. However more and more such triggers will be added in the future.

The good thing is, even if I don't have the mini menubar by default on standard screens, it will be very easy to create your own template that has it. The template files are locaated in ~/Library/Application Support/BetterTouchTool

I haven't tested it yet, but it should be enough to add this to the BTTNotchBarUser.css to always show the mini Touch Bar:

.mini-menubar-hidden {
display:block !important;

1 Like

i see ,thanks !

oh i didnt ask you to add per-app support,i actually meant to implement something like this GitHub - sindresorhus/touch-bar-simulator: Use the Touch Bar on any Mac

which relies,i think,on xcode touchbar thing (which gives a touchbar to non-compatible devices )

unfortunately these simulators just provide a video stream of what "display data" macOS provides for the Touch bar, however they are not customizable at all, thus this will not be added to BTT. The Touch Bar Simulator from Sindre Sorhus does this already as good as possible given the limitations.

correct,i meant to have it shown at the top as a replacement of touchbar for the new mac lol

i gotcha.thanks for all

@Andreas_Hegenberg is there a command or anything to avoid the notchbar being all black? i mean on a purple wallpaper i can very well see my icons and surely dont need to have it black

or was the purpose of nothcbar to hide the notch ?

Yes that was one of the purposes. But you can change the color to anything you want by editing this file: ~/Library/Application Support/BetterTouchTool/NotchBar/BTTNotchBarUser.css

You can use anything that's allowed in css background properties, e.g.

:root {
	--notchbar-background: linear-gradient(90deg, rgba(2,0,36,1) 0%, rgba(9,9,121,1) 35%, rgba(0,212,255,1) 100%);

You just need to reload the notchbar afterwards or restart BTT

Amazing thank you

Nah i don't want any color in particular,just to have the same color as the wallpaper...just as it would be with notchbar off .I suppose that's not possible? To disable the "notchbar on= apply black background"

you can also set background images, but it‘s not yet possible to have that transparent look through effect of the standard macOS menubar, this will be available as an option soon.

1 Like

I'll wait ,thank u

@Andreas_Hegenberg im sorry to bother you again ,not sure the bugs reports should be made here .but this is pretty straightforward: i cant turn notchbar off.
tried everything,toggle "enable nothbar" on and off 10 times,relaunched btt,restarted the computer ...

as u can see in the pic ,notchbar is disabled yet its still shown in menu bar

are you on the latest alpha? You should also be able to right click the bar and select „hide notchbar“

Yep latest alpha.i swear i didn't change anything in plist or anything lol,but look what happened :

I was able to change by toggling it with right click but oh man did it mess things up !

I had to reboot ,because the display didn't know which ratio to use ,the font and letters were disfigured ,the notch litteraly disappeared as you can see in the pic below

When trying to use Fullscreen the dock got killed and the app(chrome in this case ) started moving from left to the right ,not centered :joy:,kinda dancing .

Right now what remains from the bug is that

1)i cannot activate notchbar anymore but perhaps should I use a keyboard shortcut

2)when switching desktops ,the menu bar is still in solid black during the transition time,and only gets transparent/blurred background when the desktop is static .see in pics

Also another bug report i make you :

Nothhbar has messed up menu bar

For example when switching apps ,going from better touch tool to chrome,the menu-bar elements still display btt and its settings ,instead of showing chrome's (chrome,file,modify...history,profiles )

In the pic below you can see I'm using better touch tool,yet menu bar shows chrome elements

Happened all the time since the first notchbar alpha

do you know a way to reset only notchbar settings and stuff ? or should i clean reinstall btt entirely?
maybe deleting /notchbar from application support in library ?or some container?

The Notch Bar really does not influence the macos menubar, it’s just an overlay. When it’s hidden it doesn’t do anything. What you are seeing does not seem to be related to BTT.

Or does the behavior restore when you quit BTT?

The thing with the Chrome menu items can happen, this is a bug in macOS related to BTT not being a real application but a background applications. These usually do not have menu items, thus sometimes macOS "forgets" BTT has some menu items. It should not happen for other applications.

Correct ,the behavior happens only when BTT is open ,once i quit it totally none of these things happen

Besides i cannot enable notchbar anymore ,be it with a shortcut,right clicking the menu bar,nothing ,i only get the bugs and not the benefits lol

Oh i will see but I think it happened with other apps as well ,I'll let you know

Very weird, however this is definitely not related to BTT, it does not influence these things. Which version of macOS Motnerey are you currently running? Apple has fixed many notch related issues in macOS 12.1

You could try to reset BTT completely.

To do this, quit BTT, then run these terminal commands:

defaults delete com.hegenberg.BetterTouchTool


rm -rf ~/Library/Application Support/BetterTouchTool

However this will get rid of any configuration you have in BTT.