My macOS shortcuts from shortcuts app are not being shown in the list in the action configuration pane

Version 14.3.1

That should be fine, I haven't head of crashes on these new macOS versions.
Is there maybe something special about your Shortcut names?

Unfortunately only Apple would be able to look into these / fix crashes with Shortcuts Events. Are there crash logs available?

I would love to supply you with those. Can I email them to you?

Sure (one or two will be enough) -

I think your log doesn't show a crash. What makes you think Shortcuts Events crashed?

If I click the floating menu button that triggers a shortcut, and nothing happens, I switch to Terminal and type killall "Shortcuts Events". I then click the button, and the shortcut will run.

Is it maybe stuck running another shortcut? Mhh, but it should have some sort of timeout.

What does your shortcut do?

If it hangs, can you still run the shortcut via terminal?

shortcuts run "nameofshortcut"

It works consistently when I run the shortcut with your Terminal command. But I can only run 1 shortcut from a BTT button before I have to enter the killall command again.

The shortcuts all use Things actions. (The floating menu adds custom functionality to Things)

Unfortunately I can't really tell why that would be happening, it sounds like a bug in Shortcuts. I tried to reproduce, but it still seems to work fine with all my shortcuts.

Have you already tried to restart your system?

Maybe use the "Run terminal command" action in BTT instead. You'd just need to make sure to provide the full path to shortcuts, e.g.

/usr/bin/shortcuts run "shortcutname"

Thanks, that would be a great solution. It could also be that there is a bug in Things' shortcuts of course.