My gestures on opening a TB conditional action group no longer work least, not as they did until recently.

Describe the bug

Until an update in the last few days I had single finger gestures that triggered when a touchbar group was opened, and when the gestures was done they closed the group. Basically I was able to reproduce Apple's volume and brightness sliders (without the visual slider on the touchbar). If I dragged from the volume or brightness icon on my touchbar, the TB group would open and the hud would come up on the screen, and when I stopped dragging my touchbar would come back.

After a recent update, the gesture no longer triggers when the TB group opens. I have to tap a second time and drag from there. This no longer works in the current version or the alpha. It does work in 1612. I didn't try any in between.

It was useful.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


In this video, there are a single drag from the touchbar buttons. This no longer works.

Device information:

  • Type of Mac: MBP 2018
  • macOS version: 10.15.6
  • BetterTouchTool version: (please post the exact version - not just "the latest one"): Works in 1612. Doesn't work in 3.400 or alpha as of today.

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Preset here:
Awesome.bttpreset (682.7 KB)

Just a note that it doesn't seem to be working in any of the new releases in the last week either.

This still seems to work fine here with the latest versions. Could you check whether the preset I provided here works for you?

The preset in that thread doesn't work for me either (seems to be the exact same setup).

Same result. I have to tap again when the group opens for the gesture to work.

When I posted back in August, I was on an Intel MBP with Catalina. Now on an M1 MBP with Big Sur with BTT set up from scratch.

It originally stopped working for me with 3.400. At the time I went back to the previous version I had and continued to use that until I just now moved to this new computer.

Very weird, maybe it depends on the Touch Bar model.
To rule out any setting that would interfere with this, could you go to Help => Export Diagnostic Debug Info and send it to referencing this thread?

Then I could try your exact setup here.


I also just tried your preset on a Guest user (so clean BTT setup) and still got the same result.

Thank you! I can reproduce the issue with your settings. I'm looking into it!

I don't have a real fix yet, but as far as I can see a good workaround is to add an empty four finger swipe to the root level triggers. This will prevent the gesture recognition from getting disabled:

It seems that in some situations (I'm not yet sure when exactly), enabling the gesture recognition when the new view appears is too late.

This should now be fixed in 3.540 alpha!

Amazing! Thank you.