Multiple trivial triggers now failing, can’t narrow down why

  • Sorry, I couldn’t see where I can get alpha versions so haven’t tested that
  • I have rebooted
  • No repeatable crashing

  • Please see attached DnD toggle trigger as an example. This pattern is repeated for many trivial triggers that have worked for years previously.
  • upon hitting ^⌥⌘D , I get the universal MacOS “Nope!” Error sound
  • the DnD status does not change
  • this was one of my earliest triggers and has worked for… 4+ years
  • it seemed to stop within the last 2 weeks, possibly when I had some issues with presets that required some rebuilding. Hence it’s probably my error, I just don’t have the tools e.g. a useful log message, to see what it’s complaining about.

  • MBP inbuilt Keyboard

  • N/A

Device information:

  • Type of Mac: M1 MBP , 16-inch, 2021
  • macOS version: 14.4 (23E214)
  • BetterTouchTool version: 4.458

  • Please just point me at the right resources and I’ll do the legwork!
    dnd_trigger.bttpreset (698 Bytes)

FYI I just :

  1. deselected all presets,
  2. created a new one,
  3. selected the new one,
  4. deselected all the others,
  5. re-created the trigger

and exactly the same behaviour is observed.


Oh, I also tried 4.368 - same behaviour.

Your trigger looks fine, so that's not the issue.

1.) Make sure BTT is not disabled for some reason:

2.) If that doesn't help, try to reset the BTT permissions using this terminal command. Quit BTT before doing so:

tccutil reset All com.hegenberg.BetterTouchTool

When launching BTT the next time it will ask you to grant all permissions again.

The man himself! :smiley: :pray:t2:

So, I didn’t have BTT showing in the status bar, and so I enabled it, and also the Dock for good measure and the attached familiar (but not seen for some time) dialog popped up regarding the accessibility service. I duly followed the instructions êt voila, my little DnD trigger’s now working. So thanks!

BTW The docco link on the popup is busted. It takes you to, which does not exist. Maybe that link just needs pointing at instead?