Moving windows recently stopped working

Hello there! I'd love your help to debug my issue with moving windows

Unable to move windows with shortcut keys


I am able to resize windows with moving windows with the ctrl + cmd shortcut keys don't work.

Affected input device: Keyboard keys + mouse

  • I have been a user for years and use the resize / move window keys as part of my every day workflow. (I hadn't fully appreciated how much my muscle memory wants to use the move windows shortcut until now!)
  • I have upgraded to the latest BTT alpha and read recent user reports.
  • I also just tried removing / adding all permissions again as well as uninstalling + reinstalling BTT.
  • I tried these instructions (window moving and resizing - #4 by Andreas_Hegenberg) and it didn't seem to work for me.
  • Finally, I also tried various combinations of resetting the shortcut keys, enabling / disabling the helper in BTT.

Device information:

  • Type of Mac: MacBook Pro (15-inch, 2018)
  • macOS version: macOS Big Sur 11.2 (20D64, just upgraded today); for the past few weeks, I was on Catalina and hoped the version upgrade would fix it!
  • BetterTouchTool version: 3.553 (on alpha release)

Can you think of any app that may conflict with the window moving on your machine?

I know two apps that can break it: The macOS on-screen keyboard and Dragon Dictate

Hi there! I was able to resolve this issue by doing a deeper uninstall (of preferences and supporting files). Thank you for the tip and fast feedback Andreas! Love this tool and recommend it to many friends / colleagues.

I'm facing the issue that some applications cannot be moved/resized. Most applications work but some (parts of) windows seem unaffected.

Examples:

  • KeepassXC (https://keepassxc.org/)
  • Part of the finder window (the part that shows a connected phone), see attached images

Any ideas?

I have the same problem since some days.
But during writing this lines I found the problem: a BTT bug what I wanted to report anyway (it is there since at least 1 year):
In BTT Settings (see screenshot) you can see two lines with a very small hight. The first is just a headline but the second line (with a hight of 2 retina pixels!) contains one (or more) setting/s

I got the the (almost completely hidden) check activated and.. voila.. it worked again!
btw: Resizing the window does not help, the lines hight keeps the same
(MBAir M1, Monterey)

Imprint | Privacy Policy