"Move Window to Desktop 9" is sending my windows to Desktop 10 instead

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
I think there could be a bug causing this in BetterTouchTool. It's been occurring somewhere in the realm of a month or two. I am running an external display that hosts spaces 1-10 and the MacBook display beneath it hosts spaces 11 & 12

My hotkeys for space management are
Shift+Ctrl+1 => "Move to Desktop 1"
Shift+Ctrl+2 => "Move to Desktop 2"
Shift+Ctrl+9 => "Move to Desktop 9"
Shift+Ctrl+0 => "Move to Desktop 10"

For some reason Shift+Ctrl+9 sends it to Desktop 10 instead of to Desktop 9! All the others function as expected. I've tried deleting and recreating the rule. I've tried rebooting. I've tried deleting and recreating the spaces.

Mind taking a look if it could be a bug?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 16inch M1 MacBook Pro
  • macOS version: Ventura 13.1
  • BetterTouchTool version: 4.062 (but I have experienced the issue for some time now)

**Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.)

Thanks for taking a look! I love this software. Huge fan.