Move window one space = hates VS Code

Describe the bug

Since updating to Ventura (straight to 13.5 from 14.x) I've noticed the "move window one space" doesn't work on VS Code. It works on other apps just fine, and even moves ME to the other space, but VS Code just stands there looking dumb :slight_smile:

Not sure what could cause it, but it works with every other app.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Device information:

  • Type of Mac: M2 16" MBP
  • macOS version: Ventura 13.5
  • BetterTouchTool version: 4.322

Additional information (e.g. crash logs, related issues, etc.):

I looked over other issues / tried to flex my Google Fu, but I haven't found any other posts about VS Code specifically. I also have verified it doesn't happen with other Electron apps :confused:

** VS Code Details **

Version: 1.84.2
Commit: 1a5daa3a0231a0fbba4f14db7ec463cf99d7768e
Date: 2023-11-09T10:52:57.054Z
Electron: 25.9.2
ElectronBuildId: 24603566
Chromium: 114.0.5735.289
Node.js: 18.15.0
OS: Darwin arm64 22.6.0

Is there a way to bump this thread? I still can't move VSCode windows, which is the major value of BTT for me.

FWIW I see this on IntelliJ as well.

I will add a workaround for VSCode soon. The reason it is happening is actually a weird bug in VSCode, it doesn't allow dragging the window near the window buttons:


BTT by default moves the cursor to a fixed position near the window buttons to initiate a special drag that moves the window to another space.

BTT 4.357 alpha (uploading now) should work with VSCode

Thanks @Andreas_Hegenberg! And sorry to be noisy :sweat_smile:

VS Code fix confirmed. It looks like it's also happening on IntelliJ as well still.

I don't run tons of windows for IJ, but I'd imagine most of JetBrains products would be in the same boat. Sorry I didn't catch before or I would have included in the OG post.

I only have Android Studio right now, which seems to work with the default values.

However I added a (ugly) way to modify the values:

defaults write com.hegenberg.BetterTouchTool space-switch-xy-lowerCasebundleIdentifierOfApp "{x, y}"

This needs to be executed while BTT is quit. For intelliJ maybe try the same values I use for VSCode:
defaults write com.hegenberg.BetterTouchTool space-switch-xy-com.jetbrains.intellij "{130, 5}"

Depending on the IntelliJ version the bundle identifier might be different.

This sets the dragging anchor from the top left of the window.

I tried this to fix PyCharm and other JetBrains products with the defaults write method you proposed with no success unfortunately. I did find a somewhat manual workaround I mentioned here: Issue with "Move Window One Space/Desktop Left/Right"

Could you take a look at that and see if there's a way to fix this for Jetbrains products please?