"Move Window..." keyboard shortcuts not working


Grateful BTT user here with lifetime license, first time posting. I have recently started expanding my use of BTT (mostly for window snapping/manipulation) and I absolutely love it. However, for the first time I have encountered a bug that doesn't seem to be going away and would really appreciate it if anyone here can figure out what's going on and offer a solution. Much thanks in advance.

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

  • BTT version: 4.468 (same result with previous versions)
  • Device: M3 MacBook Air 13 in (same result on M1 MacBook Air 13 in)
  • macOS: 14.4.1 (same result in macOS 13.6.5)
  • I have restarted my system multiple times but same result.
  • This issue does not result in a crash of BTT.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

  • The bug concerns "Move window one space/desktop right/left" and "Move window to desktop 1,2,3..."
  • I use keyboard shortcuts as triggers ("option + right/left arrow" to move right/left; "fn + shft + b~/, h~' " to move to specific desktops).
  • The shortcuts don't work every time; however, they do work once every few tries (sometime 4, sometimes 10...).
  • Every time I press the shortcut, the cursor momentarily jumps from wherever it was on the screen to the top left area of the focused window (red arrow in the screenshot below) and then jumps back to its original position.
  • If I move one finger across the trackpad (no other keys pressed) the moment the cursor jumps to the top left area of the focused window, the window moves accordingly.
  • Assigning different shortcuts yields the same result.


Below is a screen recording of the action performed multiple times.

BTT makes use of the fact that dragging a window while switching spaces, will move the window to the new space.
Thus it moves your mouse cursor to a pre-defined position of the active window and initiates a drag, then it performs the shortcut for switching the space.

It triggers the shortcuts from System Settings => Keyboard => Keyboard Shortcuts => Mission Control

So that explains your cursor jumping and window moving.
However I currently don't have an idea why it's not working for you. I just verified that it still works here. I'd assume something is interfering :-/

Thank you for your prompt reply. So I guess this is just an issue on my devices... Maybe I can try it in safe mode or use the older M1 to disable other shortcuts and see if I can identify what's interfering the action. I'll report back if anything changes.

In the meantime, I'd really appreciate it if anyone has any solution or methods of identifying the problem. I a novice at coding (although I can follow simple instructions) so please be gentle :wink: