Move Space Left/Right Stopped Working

  • Type of Mac: MacBook Pro 16 (2019)
  • macOS version: Sonoma 14.4.1
  • BetterTouchTool version: 4.465

I just updated to this version of BTT, I had an older version (2.x) that has been running these commands since I got the license back in 2015. Somehow today, It got messed up. It started with regardless if I toggle left or right (using a tilt wheel on Microsoft Ergo Mouse), the full screen app will only go right. When I reach the last app I could not toggle back (going left) to back to my list of full screen app. Then I saw some info on here to check My Mission Control. Under Move left/right a space, it shows CTRL+ arrow left/right. Now I can't even toggle right or left. I lost that functionality. I have 2 more that seems to work okay (lock screen and browser back button). I used these Swipe Left/Right a lot especially during meetings and now it's all gone. Help is much appreciated

  • Type of Mac: MacBook Pro 14" (2021)
  • macOS version: Sonoma 14.4.1
  • BetterTouchTool version: 4.504

I am also experiencing this issue now after recently upgrading to Sonoma and updating to BTT 4.504.

I turned on the HUD overlay to make sure the trigger is being fired, and if I put another action after "Move Left a Space" the second action still works (testing with big/normal cursor toggle).

I just discovered that somehow this action works only when Secure Input is activated and I have "limited shortcut functionality".

I can't make sense of that at all.
@Andreas_Hegenberg any ideas?

@Paul_Jose and all,

Still no real solution here for the "Move [Left/Right] a Space" action, but I ended up with a workaround.

Under Settings | Keyboard | Keyboard Shortcuts | Mission Control:
I set the equivalent actions to ⌃⌥← and ⌃⌥→

And then changed the BetterTouchTool gestures to simply use "Send Keyboard Shortcut" actions.

I'm having trouble with this too. MacOS 13.6.4, BTT 4.504. Move left works as expected; move right moves left.

I was a dedicated user of TotalSpaces, but since it was abandoned and the TotalSpaces3 neverending beta crashes a few times a day, I configured BTT to take over that role. But now it's broken too. :frowning: I believe this began when I updated to MacOS 13. I updated BTT just to see if it could repair the loss. Nope.

Under standard circumstances, behavior doesn't appear to be different if I enable secure input (e.g. by running sudo ls in a terminal).

If I run TotalSpaces3 at the same time, with the same key mapped to the same action in both TS3 and BTT — I know, but stay with me here — BTT gets the input and moves left for either move left or move right events. But now if I enable secure input, BTT doesn't process the move right stroke, and TS3 does. That's interesting just as a reveal of what BTT is/isn't doing. I don't expect anyone to explain TS3. (It probably goes to a lower level to steal input, but no matter.)